Bug 117308

Summary: [CSS Shapes] Rename updateLineBoundariesForExclusions to updateLineBoundariesForShapes
Product: WebKit Reporter: Zoltan Horvath <zoltan>
Component: CSSAssignee: Zoltan Horvath <zoltan>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, esprehn+autocc, glenn
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 89256    
Attachments:
Description Flags
proposed patch achicu: review+, achicu: commit-queue-

Description Zoltan Horvath 2013-06-06 10:33:04 PDT
We have a standalone specification for CSS Shapes now: ‚Äčhttp://dev.w3.org/csswg/css-shapes/
so this change renames updateLineBoundariesForExclusions to updateLineBoundariesForShapes.
Comment 1 Zoltan Horvath 2013-06-06 10:36:23 PDT
Created attachment 203949 [details]
proposed patch
Comment 2 Alexandru Chiculita 2013-06-06 14:53:14 PDT
Comment on attachment 203949 [details]
proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=203949&action=review

> Source/WebCore/rendering/RenderBlock.h:1087
> +    void updateLineBoundariesForShapes(ExclusionShapeInsideInfo*, LayoutUnit&, LineLayoutState&, bool&);

nit: the name is a little confusing. what about updateShapeAndSegmentsForCurrentLine ?
Comment 3 Zoltan Horvath 2013-06-06 15:49:22 PDT
(In reply to comment #2)
> nit: the name is a little confusing. what about updateShapeAndSegmentsForCurrentLine ?

Thanks for the review!

Updated and landed in: http://trac.webkit.org/changeset/151295