Bug 114706

Summary: Need a new layout milestone to notify bundle clients when the header has been flushed
Product: WebKit Reporter: Beth Dakin <bdakin>
Component: Layout and RenderingAssignee: Beth Dakin <bdakin>
Status: RESOLVED FIXED    
Severity: Normal CC: bdakin, commit-queue, esprehn+autocc, sam, simon.fraser
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch simon.fraser: review+

Description Beth Dakin 2013-04-16 15:24:36 PDT
There is API to give a WKView a header, and we need a new layout milestone to notify bundle clients when that header has been flushed.

<rdar://problem/13657284>
Comment 1 Beth Dakin 2013-04-16 15:32:46 PDT
Created attachment 198444 [details]
Patch
Comment 2 Simon Fraser (smfr) 2013-04-16 15:45:16 PDT
Comment on attachment 198444 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=198444&action=review

> Source/WebCore/rendering/RenderLayerCompositor.cpp:382
> +            if (page->layoutMilestones() & DidFirstFlushForHeaderLayer) {

Maybe we can rename Page::layoutMilestones() to Page::requestedLayoutMilestones() in a future patch to make its role clearer.

> Source/WebKit2/Shared/API/c/WKPageLoadTypes.h:55
> +    // Note that this enum has a fourth, private member that is defined in WKPageLoadTypesPrivate.h

I think it would be better to add 
kWKReserved1 = 1 << 3 or something, so that future changes are less likely to break things.
Comment 3 Beth Dakin 2013-04-16 16:00:20 PDT
(In reply to comment #2)
> (From update of attachment 198444 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=198444&action=review
> 
> > Source/WebCore/rendering/RenderLayerCompositor.cpp:382
> > +            if (page->layoutMilestones() & DidFirstFlushForHeaderLayer) {
> 
> Maybe we can rename Page::layoutMilestones() to Page::requestedLayoutMilestones() in a future patch to make its role clearer.
> 

Good idea. Will do.

> > Source/WebKit2/Shared/API/c/WKPageLoadTypes.h:55
> > +    // Note that this enum has a fourth, private member that is defined in WKPageLoadTypesPrivate.h
> 
> I think it would be better to add 
> kWKReserved1 = 1 << 3 or something, so that future changes are less likely to break things.

Changed this!

http://trac.webkit.org/changeset/148564