Bug 114127

Summary: Do not check if WTF_ARM_ARCH_VERSION is defined in WTF_ARM_ARCH_AT_LEAST macro
Product: WebKit Reporter: Patrick R. Gansterer <paroga>
Component: New BugsAssignee: Patrick R. Gansterer <paroga>
Status: RESOLVED FIXED    
Severity: Normal CC: benjamin, cmarcelo, ojan.autocc, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch benjamin: review+, benjamin: commit-queue-

Description Patrick R. Gansterer 2013-04-07 12:04:03 PDT
Do not check if WTF_ARM_ARCH_VERSION is defined in WTF_ARM_ARCH_AT_LEAST macro
Comment 1 Patrick R. Gansterer 2013-04-07 12:09:38 PDT
Created attachment 196797 [details]
Patch
Comment 2 Benjamin Poulain 2013-04-07 14:26:46 PDT
Comment on attachment 196797 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=196797&action=review

> Source/WTF/ChangeLog:9
> +        Platform.h defines WTF_ARM_ARCH_VERSION always and removing the
> +        check works around a bug in older Microsoft compiler versions.

Please fix the changelog.
Comment 3 Patrick R. Gansterer 2013-04-07 15:07:19 PDT
Committed r147881: <http://trac.webkit.org/changeset/147881>
Comment 4 Patrick R. Gansterer 2013-04-07 16:28:45 PDT
*** Bug 114125 has been marked as a duplicate of this bug. ***