Bug 111776

Summary: REGRESSION: fast/border/border-fit-2.html needs updating
Product: WebKit Reporter: Dave Hyatt <hyatt>
Component: Layout and RenderingAssignee: Dave Hyatt <hyatt>
Status: RESOLVED FIXED    
Severity: Normal CC: eric, jonlee, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch simon.fraser: review+

Description Dave Hyatt 2013-03-07 14:26:36 PST
This test is incorrectly shrinking the border image because we need to apply some clamping to the border-fit. The pixel results *are* still changing though, since a layout-time shrinkage will not result in right-aligned boxes in an LTR block when the left edge gets chopped. We'll have to see if this behavioral change ends up being a problem, but for now we'll rebaseline and assume it will be ok.
Comment 1 Dave Hyatt 2013-03-07 14:30:08 PST
Created attachment 192085 [details]
Patch
Comment 2 Simon Fraser (smfr) 2013-03-07 14:31:46 PST
Comment on attachment 192085 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=192085&action=review

> Source/WebCore/ChangeLog:10
> +        old code did.. The pixel results *are* still changing though,

Two periods.

> Source/WebCore/ChangeLog:26
> +        Need a short description (OOPS!).
> +        Need the bug URL (OOPS!).
> +
> +        Reviewed by NOBODY (OOPS!).
> +
> +        No new tests (OOPS!).

OOPS!
Comment 3 Dave Hyatt 2013-03-07 14:36:35 PST
Landed in r145139.
Comment 4 Eric Seidel (no email) 2013-03-07 14:37:20 PST
Someone should tell hyatt about webkit-patch land, which magically updates the bug for you. :)
Comment 5 Radar WebKit Bug Importer 2013-03-13 21:17:50 PDT
<rdar://problem/13417623>