Bug 111266

Summary: REGRESSION(r144567): Does not compile on apple-win (Requested by abarth on #webkit).
Product: WebKit Reporter: WebKit Review Bot <webkit.review.bot>
Component: New BugsAssignee: WebKit Review Bot <webkit.review.bot>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 109061    
Attachments:
Description Flags
ROLLOUT of r144567 none

Description WebKit Review Bot 2013-03-03 02:29:41 PST
http://trac.webkit.org/changeset/144567 broke the build:
Does not compile on apple-win (Requested by abarth on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2013-03-03 02:30:18 PST
Created attachment 191132 [details]
ROLLOUT of r144567

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Ryosuke Niwa 2013-03-03 02:32:13 PST
Comment on attachment 191132 [details]
ROLLOUT of r144567

I’ll try my fix first.
Comment 3 Ryosuke Niwa 2013-03-03 03:42:21 PST
Comment on attachment 191132 [details]
ROLLOUT of r144567

I’ve tried several build fixes including clean builds but that didn’t help:


19>   Creating library C:\cygwin\home\buildbot\slave\win-release\build\WebKitBuild\Release\lib\DumpRenderTree.lib and object C:\cygwin\home\buildbot\slave\win-release\build\WebKitBuild\Release\lib\DumpRenderTree.exp
19>WebCoreTestSupport.lib(JSInternals.obj) : error LNK2019: unresolved external symbol "class JSC::JSValue __cdecl WebCore::toJS(class JSC::ExecState *,class WebCore::JSDOMGlobalObject *,class WebCore::CSSStyleDeclaration *)" (?toJS@WebCore@@YA?AVJSValue@JSC@@PAVExecState@3@PAVJSDOMGlobalObject@1@PAVCSSStyleDeclaration@1@@Z) referenced in function "__int64 __fastcall WebCore::jsInternalsPrototypeFunctionComputedStyleIncludingVisitedInfo(class JSC::ExecState *)" (?jsInternalsPrototypeFunctionComputedStyleIncludingVisitedInfo@WebCore@@YI_JPAVExecState@JSC@@@Z)
19>C:\cygwin\home\buildbot\slave\win-release\build\WebKitBuild\Release\bin\DumpRenderTree.dll : fatal error LNK1120: 1 unresolved externals
Comment 4 WebKit Review Bot 2013-03-03 03:49:47 PST
Comment on attachment 191132 [details]
ROLLOUT of r144567

Clearing flags on attachment: 191132

Committed r144572: <http://trac.webkit.org/changeset/144572>
Comment 5 WebKit Review Bot 2013-03-03 03:49:50 PST
All reviewed patches have been landed.  Closing bug.