Bug 111212

Summary: [V8] Rename getWorld() to isolatedWorld(), and getWorldForEnteredContext() to isolatedWorldForEnteredContext()
Product: WebKit Reporter: Kentaro Hara <haraken>
Component: WebCore JavaScriptAssignee: Kentaro Hara <haraken>
Severity: Normal CC: abarth, dcarney, japhet, mkwst+watchlist, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch webkit.review.bot: commit-queue-

Description Kentaro Hara 2013-03-01 12:47:00 PST
The rename I did in r142424 was wrong. Given that getWorld() returns 0 for the main world, it should be named isolatedWorld(). Similarly, given that getWorldForEnteredContext() returns 0 for the main world, it should be named isolatedWorldForEnteredContext().
Comment 1 Kentaro Hara 2013-03-01 12:54:11 PST
Created attachment 191016 [details]
Comment 2 Adam Barth 2013-03-02 23:11:01 PST
Comment on attachment 191016 [details]

Comment 3 WebKit Review Bot 2013-03-02 23:37:32 PST
Comment on attachment 191016 [details]

Rejecting attachment 191016 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=webkit-commit-queue.appspot.com', '--bot-id=gce-cq-04', 'build', '--no-clean', '--no-update', '--build-style=release', '--port=chromium-xvfb']" exit_code: 2 cwd: /mnt/git/webkit-commit-queue

Last 500 characters of output:
WebCore/bindings/v8/V8MutationCallback.cpp -o obj/Source/WebCore/bindings/v8/webcore_remaining.V8MutationCallback.o
../../Source/WebCore/bindings/v8/V8MutationCallback.cpp: In constructor 'WebCore::V8MutationCallback::V8MutationCallback(v8::Handle<v8::Object>, WebCore::ScriptExecutionContext*, v8::Handle<v8::Object>, v8::Isolate*)':
../../Source/WebCore/bindings/v8/V8MutationCallback.cpp:41: error: 'getWorld' is not a member of 'WebCore::DOMWrapperWorld'
ninja: build stopped: subcommand failed.

Full output: http://webkit-commit-queue.appspot.com/results/16899158
Comment 4 Kentaro Hara 2013-03-03 16:07:50 PST
Committed r144587: <http://trac.webkit.org/changeset/144587>