Bug 110303

Summary: webdatabase: Rename DatabaseBackend to DatabaseBackendBase
Product: WebKit Reporter: Mark Lam <mark.lam>
Component: WebCore Misc.Assignee: Mark Lam <mark.lam>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, andersca, ap, beidson, dglazkov, fishd, ggaren, gyuyoung.kim, jamesr, levin+threading, michaeln, rakuco, sam, tkent+wkapi, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
the patch. ap: review+

Description Mark Lam 2013-02-19 22:05:28 PST
Renaming DatabaseBackend to DatabaseBackendBase.  This makes it consistent with the frontend DatabaseBase.  Similarly, we should rename DatabaseBackendAsync to DatabaseBackend to parallel its frontend Database, but we'll do this part in another bug.

This patch is purely cosmetic.  Apart from cleaning up #include in DatabaseBase.h, there are no other changes that are not purely due to the rename.
Comment 1 Mark Lam 2013-02-19 22:13:08 PST
Created attachment 189241 [details]
the patch.
Comment 2 WebKit Review Bot 2013-02-19 22:15:49 PST
Please wait for approval from abarth@webkit.org, dglazkov@chromium.org, fishd@chromium.org, jamesr@chromium.org or tkent@chromium.org before submitting, as this patch contains changes to the Chromium public API. See also https://trac.webkit.org/wiki/ChromiumWebKitAPI.
Comment 3 WebKit Review Bot 2013-02-19 22:17:21 PST
Attachment 189241 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/WebCore/ChangeLog', u'Source/WebCore/GNUmakefile.list.am', u'Source/WebCore/Modules/webdatabase/AbstractDatabaseServer.h', u'Source/WebCore/Modules/webdatabase/Database.cpp', u'Source/WebCore/Modules/webdatabase/Database.h', u'Source/WebCore/Modules/webdatabase/DatabaseBackend.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseBackend.h', u'Source/WebCore/Modules/webdatabase/DatabaseBackendAsync.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseBackendAsync.h', u'Source/WebCore/Modules/webdatabase/DatabaseBackendBase.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseBackendBase.h', u'Source/WebCore/Modules/webdatabase/DatabaseBackendSync.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseBackendSync.h', u'Source/WebCore/Modules/webdatabase/DatabaseBase.h', u'Source/WebCore/Modules/webdatabase/DatabaseManager.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseManager.h', u'Source/WebCore/Modules/webdatabase/DatabaseServer.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseServer.h', u'Source/WebCore/Modules/webdatabase/DatabaseSync.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseSync.h', u'Source/WebCore/Modules/webdatabase/DatabaseTracker.cpp', u'Source/WebCore/Modules/webdatabase/DatabaseTracker.h', u'Source/WebCore/Modules/webdatabase/OriginQuotaManager.cpp', u'Source/WebCore/Modules/webdatabase/OriginQuotaManager.h', u'Source/WebCore/Modules/webdatabase/SQLTransactionClient.cpp', u'Source/WebCore/Modules/webdatabase/SQLTransactionClient.h', u'Source/WebCore/Modules/webdatabase/chromium/DatabaseObserver.h', u'Source/WebCore/Modules/webdatabase/chromium/DatabaseTrackerChromium.cpp', u'Source/WebCore/Modules/webdatabase/chromium/SQLTransactionClientChromium.cpp', u'Source/WebCore/Target.pri', u'Source/WebCore/WebCore.gypi', u'Source/WebCore/WebCore.vcproj/WebCore.vcproj', u'Source/WebCore/WebCore.vcxproj/WebCore.vcxproj', u'Source/WebCore/WebCore.vcxproj/WebCore.vcxproj.filters', u'Source/WebCore/WebCore.xcodeproj/project.pbxproj', u'Source/WebKit/chromium/ChangeLog', u'Source/WebKit/chromium/public/WebDatabase.h', u'Source/WebKit/chromium/src/DatabaseObserver.cpp', u'Source/WebKit/chromium/src/WebDatabase.cpp']" exit_code: 1
Source/WebCore/Modules/webdatabase/DatabaseBackendBase.h:81:  The parameter name "permissions" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 38 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Alexey Proskuryakov 2013-02-20 09:40:06 PST
Comment on attachment 189241 [details]
the patch.

rs=me
Comment 5 Dimitri Glazkov (Google) 2013-02-20 09:55:30 PST
Comment on attachment 189241 [details]
the patch.

LGTM.
Comment 6 Mark Lam 2013-02-20 09:59:40 PST
Landed in r143471: <http://trac.webkit.org/changeset/143471>.