Bug 109885

Summary: [WK2] Rename from scrollOffset to scrollDelta in WebChromeClient.
Product: WebKit Reporter: Dongseong Hwang <dongseong.hwang>
Component: WebKit2Assignee: Dongseong Hwang <dongseong.hwang>
Severity: Normal CC: andersca, rniwa, simon.fraser, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch none

Description Dongseong Hwang 2013-02-14 21:04:46 PST
Chrome sends a scroll delta to WebChromeClient but WebChromeClient names it
scrollOffset. So this patch corrects this misnaming.

In addition, all subclasses of LayerTreeHost don't use the misnamed
scrollOffset in scrollNonCompositedContents(), so this patch removes the
scrollOffset argument.
Comment 1 Dongseong Hwang 2013-02-14 21:07:01 PST
Created attachment 188475 [details]
Comment 2 WebKit Review Bot 2013-02-14 23:16:42 PST
Comment on attachment 188475 [details]

Clearing flags on attachment: 188475

Committed r142968: <http://trac.webkit.org/changeset/142968>
Comment 3 WebKit Review Bot 2013-02-14 23:16:45 PST
All reviewed patches have been landed.  Closing bug.