Bug 107860

Summary: DFG::JITCompiler::getSpeculation() methods are badly named and superfluous
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, ggaren, mark.lam, mhahnenberg, msaboff, oliver, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 106868    
Attachments:
Description Flags
the patch mhahnenberg: review+

Description Filip Pizlo 2013-01-24 13:57:38 PST
They should be called getPrediction().  But they're superfluous since it takes less typing to just call Node::prediction() anyway.
Comment 1 Filip Pizlo 2013-01-24 13:58:45 PST
Created attachment 184574 [details]
the patch
Comment 2 Mark Hahnenberg 2013-01-24 13:59:44 PST
Comment on attachment 184574 [details]
the patch

r=me
Comment 3 Filip Pizlo 2013-01-24 14:00:58 PST
Landed in http://trac.webkit.org/changeset/140719