Bug 105299

Summary: [GStreamer] webaudio/decode-audio-data-basic.html crashes
Product: WebKit Reporter: Dominik Röttsches (drott) <d-r>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: chavarria1991, eocanha, pnormand, slomo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Dominik Röttsches (drott) 2012-12-18 07:56:31 PST
crash log for WebProcess (pid <unknown>):
STDOUT: <empty>
STDERR: ASSERTION FAILED: !m_isolatedWorld->isNormal() || m_wrapper || !m_jsFunction
STDERR: /fast/dominik/dev/WebKitGit_EFL/Source/WebCore/bindings/js/JSEventListener.h(92) : JSC::JSObject* WebCore::JSEventListener::jsFunction(WebCore::ScriptExecutionContext*) const
STDERR: 1   0x7fe85fe856e2 WebCore::JSEventListener::jsFunction(WebCore::ScriptExecutionContext*) const
STDERR: 2   0x7fe85fe907d2 WebCore::JSEventListener::handleEvent(WebCore::ScriptExecutionContext*, WebCore::Event*)
STDERR: 3   0x7fe85f2d74ea WebCore::EventTarget::fireEventListeners(WebCore::Event*, WebCore::EventTargetData*, WTF::Vector<WebCore::RegisteredEventListener, 1ul>&)
STDERR: 4   0x7fe85f2d72aa WebCore::EventTarget::fireEventListeners(WebCore::Event*)
STDERR: 5   0x7fe85f2d7166 WebCore::EventTarget::dispatchEvent(WTF::PassRefPtr<WebCore::Event>)
STDERR: 6   0x7fe85ef8ba74 WebCore::ScriptProcessorNode::fireProcessEvent()
STDERR: 7   0x7fe85ef8b84b WebCore::ScriptProcessorNode::fireProcessEventDispatch(void*)
STDERR: 8   0x7fe8604a784d WTF::dispatchFunctionsFromMainThread()
STDERR: 9   0x7fe8604d5958
STDERR: 10  0x7fe863e9d917
STDERR: 11  0x7fe863e9c6a1
STDERR: 12  0x7fe863e9cbe7 ecore_main_loop_begin
STDERR: 13  0x7fe86037d2d7 WebCore::RunLoop::run()
STDERR: 14  0x7fe8639885d3 WebProcessMainEfl
STDERR: 15  0x4007d4 main
STDERR: 16  0x7fe862bdf76d __libc_start_main
STDERR: 17  0x4006f9
Comment 1 Dominik Röttsches (drott) 2012-12-18 08:20:01 PST
webaudio/javascriptaudionode-upmix2-8channel-input.html is flaky and sometimes crashes with the same stacktrace.
Comment 2 Philippe Normand 2012-12-21 12:27:53 PST
Dupe of bug 80681 I think
Comment 3 Philippe Normand 2012-12-30 09:14:59 PST
I couldn't reproduce this bug in a GTK Debug build.
Comment 4 Alexey Proskuryakov 2013-10-07 23:13:31 PDT
See also: bug 120148.
Comment 5 Sebastian Dröge (slomo) 2014-12-07 08:39:23 PST
webaudio/javascriptaudionode.html is reliably succeeding here for me. Some other tests are flaky and sometimes succeed although they're expected to fail.

webaudio/codec-tests/24bit-22khz-resample.html is failing for me reliably because of audio mismatch. Which might be related to the resampler not giving bit exact output on all architectures, e.g. if SSE2 is used instead of normal operations.
Comment 6 Marcos Chavarría Teijeiro (irc: chavaone) 2015-03-13 02:42:13 PDT
This test is passing after r176259.

Updating TestExpectations at:
https://bugs.webkit.org/show_bug.cgi?id=142665
Comment 7 Enrique Ocaña 2020-03-06 06:10:08 PST
This bug isn't happening anymore, closing.