Bug 104641

Summary: Coordinated Graphics: Rename LayerTreeCoordinator to CoordinatedLayerTreeHost
Product: WebKit Reporter: Gwang Yoon Hwang <yoon>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: abecsi, cmarcelo, dongseong.hwang, gyuyoung.kim, jaepark, kenneth, menard, noam, rakuco, webkit.review.bot, zeno
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Rebase after r137293 none

Description Gwang Yoon Hwang 2012-12-10 23:56:31 PST
Coordinated Graphics: Rename LayerTreeCoordinator to CoordinatedLayerTreeHost
Comment 1 Gwang Yoon Hwang 2012-12-11 00:04:20 PST
Created attachment 178736 [details]
Patch
Comment 2 Kenneth Rohde Christiansen 2012-12-11 00:58:20 PST
Comment on attachment 178736 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=178736&action=review

> Source/WebKit2/UIProcess/API/qt/qquickwebpage.cpp:73
> +    CoordinatedLayerTreeHostProxy* coordinatedLayerTreeHostProxy = webPageProxy->drawingArea()->coordinatedLayerTreeHostProxy();

I think calling the local variable for just layerTreeHostProxy is fine as it is an impl of LayerTreeHostProxy

Maybe also do this for the getter if we don't differentiate the two
Comment 3 Gwang Yoon Hwang 2012-12-11 02:00:38 PST
Created attachment 178752 [details]
Patch

Refactor QQuickWebPagePrivate to make a cleaner code.
Comment 4 Gwang Yoon Hwang 2012-12-11 13:25:03 PST
Created attachment 178861 [details]
Rebase after r137293
Comment 5 Noam Rosenthal 2012-12-11 13:53:44 PST
Comment on attachment 178861 [details]
Rebase after r137293

This is fine with me, but I'd like someone else that's affected by it (Kenneth?) to look as well and commit.
Comment 6 WebKit Review Bot 2012-12-11 14:05:03 PST
Comment on attachment 178861 [details]
Rebase after r137293

Clearing flags on attachment: 178861

Committed r137358: <http://trac.webkit.org/changeset/137358>
Comment 7 WebKit Review Bot 2012-12-11 14:05:08 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 Kenneth Rohde Christiansen 2012-12-11 16:28:15 PST
Comment on attachment 178861 [details]
Rebase after r137293

View in context: https://bugs.webkit.org/attachment.cgi?id=178861&action=review

> Source/WebKit2/UIProcess/DrawingAreaProxy.h:104
> +    OwnPtr<CoordinatedLayerTreeHostProxy> m_coordinatedLayerTreeHostProxy;

I was OK with the patch, just wondering whether it would be better to just call this like m_layerTreeHostProxy as we are supposely just a specialized version and most of the places the "coordinated" is obvious

> Source/WebKit2/UIProcess/DrawingAreaProxyImpl.cpp:372
> +        m_coordinatedLayerTreeHostProxy->didReceiveCoordinatedLayerTreeHostProxyMessage(connection, messageID, decoder);

like m_layerTreeHostProxy->didReceiveMessage ? It is almost like double here