Bug 104266

Summary: Rename ENABLE(GLIB_SUPPORT) to USE(GLIB)
Product: WebKit Reporter: Laszlo Gombos <laszlo.gombos>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: benjamin, cmarcelo, gyuyoung.kim, jaepark, mifenton, mrobinson, ojan.autocc, pnormand, rakuco, rwlbuis, tonikitoo, webkit.review.bot, yong.li.webkit, zan
Priority: P2 Keywords: EasyFix
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
pnormand: review+, pnormand: commit-queue-
Patch none

Description Laszlo Gombos 2012-12-06 08:01:27 PST
I think this would be more consistent with the existing macro naming conventions.

From Platform.h:
USE() - use a particular third-party library or optional OS service
ENABLE() - turn on a specific feature of WebKit
Comment 1 Philippe Normand 2012-12-11 00:36:21 PST
I guess this makes sense, any objection Martin?
Comment 2 Martin Robinson 2012-12-11 00:56:44 PST
No objections from me!
Comment 3 Philippe Normand 2012-12-13 06:54:32 PST
Lazlo would you provide a patch?
Comment 4 Laszlo Gombos 2012-12-13 07:22:41 PST
(In reply to comment #3)
> Lazlo would you provide a patch?

I can provide a patch but I was not planning on it. 

I wish there would be a more explicit way to mark that the bug author is not actively pursuing fixing the bug (there is of course value in just creating and filing a bug) - but I guess leaving the bug unassigned is the closest we have.

Feel free to grab it if you interested.
Comment 5 Jae Hyun Park 2013-02-08 00:06:14 PST
Created attachment 187250 [details]
Patch
Comment 6 Laszlo Gombos 2013-02-08 06:14:59 PST
I would prefer not to make changes under WebKit/blackberry as I think those changes are not necessary. As far as I can tell AboutDataUseFeatures.in is not kept up with changes.
Comment 7 Jae Hyun Park 2013-02-08 06:32:51 PST
Created attachment 187307 [details]
Patch
Comment 8 Martin Robinson 2013-02-08 07:50:04 PST
Comment on attachment 187307 [details]
Patch

Looks good to me.
Comment 9 Philippe Normand 2013-02-09 01:57:08 PST
Comment on attachment 187307 [details]
Patch

Looks good but needs to be rebased before landing!
Comment 10 Jae Hyun Park 2013-02-10 00:25:35 PST
Created attachment 187468 [details]
Patch
Comment 11 Jae Hyun Park 2013-02-10 00:27:24 PST
(In reply to comment #9)
> (From update of attachment 187307 [details])
> Looks good but needs to be rebased before landing!

Thanks for the review! 

I rebased the patch.
Comment 12 WebKit Review Bot 2013-02-10 03:25:01 PST
Comment on attachment 187468 [details]
Patch

Clearing flags on attachment: 187468

Committed r142395: <http://trac.webkit.org/changeset/142395>
Comment 13 WebKit Review Bot 2013-02-10 03:25:06 PST
All reviewed patches have been landed.  Closing bug.