Bug 103522

Summary: Coordinated Graphics: Images disappear randomly
Product: WebKit Reporter: Kalyan <kalyan.kondapally>
Component: WebKit EFLAssignee: Dongseong Hwang <dongseong.hwang>
Status: RESOLVED FIXED    
Severity: Normal CC: dongseong.hwang, jturcotte, kenneth, lucas.de.marchi, noam, webkit.review.bot, zeno
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Bug Depends on:    
Bug Blocks: 103105, 103155    
Attachments:
Description Flags
Not for review: Patch to help understanding.
none
Patch
none
Patch none

Description Kalyan 2012-11-28 06:36:58 PST
Steps to reproduce:

Load the page http://media.24ways.org/2009/14/5/index.html in MiniBrowser
Hover the mouse on any image.

Expected result:
The image is zoomed in

Actual Result:
Rest of the images seem to disappear randomly.
If the mouse is moved away from the image, all the images re-appear.


Seems to work fine with Firefox and Chrome browser.
Comment 1 Kalyan 2012-11-28 07:09:06 PST
(In reply to comment #0)
> Steps to reproduce:
> 
> Load the page http://media.24ways.org/2009/14/5/index.html in MiniBrowser
> Hover the mouse on any image.
> 
> Expected result:
> The image is zoomed in
> 
> Actual Result:
> Rest of the images seem to disappear randomly.
> If the mouse is moved away from the image, all the images re-appear.
> 
> 
> Seems to work fine with Firefox and Chrome browser.

Images also re-appear automatically after the zoom animation has finished.
Comment 2 Kalyan 2012-11-28 07:25:49 PST
(In reply to comment #1)
> (In reply to comment #0)
> > Steps to reproduce:
> > 
> > Load the page http://media.24ways.org/2009/14/5/index.html in MiniBrowser
> > Hover the mouse on any image.
> > 
> > Expected result:
> > The image is zoomed in
> > 
> > Actual Result:
> > Rest of the images seem to disappear randomly.
> > If the mouse is moved away from the image, all the images re-appear.
> > 
> > 
> > Seems to work fine with Firefox and Chrome browser.
> 
> Images also re-appear automatically after the zoom animation has finished.

Same behaviour on Qt-MiniBrowser
Comment 3 Kenneth Rohde Christiansen 2012-11-28 09:20:11 PST
Noam says that it might be related to the direct image compositing.
Comment 4 Noam Rosenthal 2012-11-28 09:24:46 PST
(In reply to comment #3)
> Noam says that it might be related to the direct image compositing.

Easy way to find out: always return false from CoordinatedGraphicsLayer::shouldDirectlyCompositeImage.
Comment 5 Dongseong Hwang 2012-11-28 15:40:44 PST
(In reply to comment #4)
> (In reply to comment #3)
> > Noam says that it might be related to the direct image compositing.
> 
> Easy way to find out: always return false from CoordinatedGraphicsLayer::shouldDirectlyCompositeImage.

We still have flash after making CoordinatedGraphicsLayer::shouldDirectlyCompositeImage return false.

However, we cannot reproduce in WK1. I think it is problem in coordinated graphics.
Comment 6 Dongseong Hwang 2012-11-28 16:21:59 PST
Created attachment 176597 [details]
Not for review: Patch to help understanding.

not for review: this patch helps us understand what is problem
Comment 7 Dongseong Hwang 2012-11-28 16:22:56 PST
(In reply to comment #6)
> Created an attachment (id=176597) [details]
> Patch
> 
> not for review: this patch helps us understand what is problem

If applying this patch, this bug is fixed. Bug I think we can find better solution.
Comment 8 Dongseong Hwang 2012-11-30 22:44:28 PST
I made it. After layout test, I'll post!
Comment 9 Dongseong Hwang 2012-12-01 02:05:53 PST
Created attachment 177097 [details]
Patch
Comment 10 Kenneth Rohde Christiansen 2012-12-01 02:12:05 PST
Comment on attachment 177097 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=177097&action=review

> Source/WebKit2/UIProcess/CoordinatedGraphics/LayerTreeCoordinatorProxy.cpp:97
>  {
>      dispatchUpdate(bind(&LayerTreeRenderer::deleteLayer, m_renderer.get(), id));
> -    updateViewport();
>  }

why is this change not explained in thechangelog
Comment 11 Dongseong Hwang 2012-12-01 02:21:26 PST
Created attachment 177098 [details]
Patch
Comment 12 Dongseong Hwang 2012-12-01 02:22:42 PST
Comment on attachment 177097 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=177097&action=review

>> Source/WebKit2/UIProcess/CoordinatedGraphics/LayerTreeCoordinatorProxy.cpp:97
>>  }
> 
> why is this change not explained in thechangelog

It's mistake. I explain in next patch!
Comment 13 WebKit Review Bot 2012-12-02 04:50:02 PST
Comment on attachment 177098 [details]
Patch

Clearing flags on attachment: 177098

Committed r136341: <http://trac.webkit.org/changeset/136341>
Comment 14 WebKit Review Bot 2012-12-02 04:50:07 PST
All reviewed patches have been landed.  Closing bug.