Bug 101733

Summary: MediaStream API: Make sure that MediaConstraints only has optional and mandatory at the top level
Product: WebKit Reporter: Tommy Widenflycht <tommyw>
Component: WebCore Misc.Assignee: Tommy Widenflycht <tommyw>
Status: RESOLVED FIXED    
Severity: Normal CC: eric.carlson, feature-media-reviews, hta, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 56459    
Attachments:
Description Flags
Patch
none
Patch none

Description Tommy Widenflycht 2012-11-09 02:33:59 PST
MediaStream API: Make sure that MediaConstraints only has optional and mandatory at the top level
Comment 1 Tommy Widenflycht 2012-11-09 02:41:32 PST
Created attachment 173249 [details]
Patch
Comment 2 jochen 2012-11-12 06:30:05 PST
Comment on attachment 173249 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=173249&action=review

> Source/WebCore/Modules/mediastream/MediaConstraintsImpl.cpp:70
> +    Vector<String>::iterator it = names.begin();

why don't you put the definition of "it" inside the for ()?
Comment 3 Tommy Widenflycht 2012-11-12 06:38:31 PST
Comment on attachment 173249 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=173249&action=review

>> Source/WebCore/Modules/mediastream/MediaConstraintsImpl.cpp:70
>> +    Vector<String>::iterator it = names.begin();
> 
> why don't you put the definition of "it" inside the for ()?

It makes it more readable imho, I guess you prefer it all in one line? Will fix.
Comment 4 Tommy Widenflycht 2012-11-12 06:46:54 PST
Created attachment 173640 [details]
Patch
Comment 5 jochen 2012-11-12 06:50:59 PST
Comment on attachment 173640 [details]
Patch

Looks good, thanks
Comment 6 WebKit Review Bot 2012-11-12 08:35:18 PST
Comment on attachment 173640 [details]
Patch

Clearing flags on attachment: 173640

Committed r134245: <http://trac.webkit.org/changeset/134245>
Comment 7 WebKit Review Bot 2012-11-12 08:35:22 PST
All reviewed patches have been landed.  Closing bug.