RESOLVED FIXED 13855
Port patch 666176 to JavaScriptCore
https://bugs.webkit.org/show_bug.cgi?id=13855
Summary Port patch 666176 to JavaScriptCore
Luciano Montanaro
Reported 2007-05-24 03:54:32 PDT
rename JSObject::downcast() to asCell(), which should make the meaning cleaner
Attachments
Change occurrences of downcast to asCell (7.11 KB, patch)
2007-05-24 03:55 PDT, Luciano Montanaro
no flags
New version of the patch, with changelog. (8.47 KB, patch)
2007-05-24 07:38 PDT, Luciano Montanaro
darin: review+
Luciano Montanaro
Comment 1 2007-05-24 03:55:53 PDT
Created attachment 14701 [details] Change occurrences of downcast to asCell
David Kilzer (:ddkilzer)
Comment 2 2007-05-24 05:19:13 PDT
Comment on attachment 14701 [details] Change occurrences of downcast to asCell Thanks for the patch! Again, please set the "review?" flag, and please review the code contribution guidelines here: http://webkit.org/coding/contributing.html
Luciano Montanaro
Comment 3 2007-05-24 07:38:54 PDT
Created attachment 14704 [details] New version of the patch, with changelog.
Darin Adler
Comment 4 2007-05-24 09:42:58 PDT
Comment on attachment 14701 [details] Change occurrences of downcast to asCell Seems fine, r=me
David Kilzer (:ddkilzer)
Comment 5 2007-05-24 09:52:26 PDT
Comment on attachment 14701 [details] Change occurrences of downcast to asCell Clearing old review flag.
Sam Weinig
Comment 6 2007-05-24 16:53:22 PDT
Landed in r21736.
Note You need to log in before you can comment on or make changes to this bug.