Bug 99626 - Unable to rebaseline windows tests
: Unable to rebaseline windows tests
Status: RESOLVED FIXED
: WebKit
Tools / Tests
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-10-17 12:15 PST by
Modified: 2012-10-17 13:23 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-10-17 12:15:34 PST
The following test are failing on the windows canary bots, but when I rebaseline them with webkit-patch rebaseline, or garden-o-matic, it does not update anything.

ietestcenter/css3/bordersbackgrounds/border-radius-content-edge-001.htm
css1/basic/inheritance.html
fast/sub-pixel/selection/selection-rect-in-sub-pixel-table.html
svg/zoom/page/zoom-svg-through-object-with-absolute-size-2.xhtml
tables/mozilla/bugs/bug73321.html

This is the 2nd day that these tests have been acting like this. They are part of a larger set, the others rebaselined successfully, but these are not.
------- Comment #1 From 2012-10-17 12:24:46 PST -------
looking
------- Comment #2 From 2012-10-17 12:32:19 PST -------
These five tests are only failing in Debug mode, and we don't check in baselines that only affect Debug if we also have Release bots in that config (since then Release would start to fail). In this situation you need to suppress the failures and file a bug for someone to figure out why we're getting different output in Debug and Release.
------- Comment #3 From 2012-10-17 12:32:52 PST -------
whoops, shouldn't have wontfix'ed this until I was sure my explanation made sense to you (I didn't actually look at the failures in detail).
------- Comment #4 From 2012-10-17 12:40:08 PST -------
Does it change anything that the release bot is still failing these tests too? Tho garden-o-matic doesn't seem aware.

http://build.chromium.org/p/chromium.webkit/builders/WebKit%20Win7/builds/143/steps/webkit_tests
------- Comment #5 From 2012-10-17 12:44:57 PST -------
Yes, that would definitely change things :). That sounds like a bug in g-o-m. Looking again.
------- Comment #6 From 2012-10-17 12:53:56 PST -------
Okay, the problem is that the Win7 Release results are not being uploaded to the correct folder, and so we're not finding them (so I think we think the tests are passing on Win7 Release). Unfortunately, garden-o-matic isn't reporting an error in this case. 

Separately, it looks like the data in Tools/Scripts/webkitpy/layout_tests/port/builders.py is wrong; I'm not sure what the implications of that is except that bad things would probably happen between win7 and xp baselines.

Working on it ...
------- Comment #7 From 2012-10-17 13:16:08 PST -------
Okay, you should be getting the windows baselines now. Let me know if you still have issues. I'll file other bugs for the lack-of-error and the builders.py issues.
------- Comment #8 From 2012-10-17 13:23:05 PST -------
Yup! Thanks :)