Bug 9790 - Paste from Clipboard behavior wrong in web page text area
: Paste from Clipboard behavior wrong in web page text area
Status: RESOLVED DUPLICATE of bug 9527
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 420+
: Macintosh PowerPC Mac OS X 10.4
: P1 Major
Assigned To: Nobody
http://houseofwarwick.com
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 09:15 PDT by Steve Kirks
Modified: 2006-07-08 09:32 PDT (History)
0 users

See Also:


Attachments
A short screen movie of the bug's behavior in a text area (76.75 KB, video/quicktime)
2006-07-08 09:17 PDT, Steve Kirks
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Kirks 2006-07-08 09:15:14 PDT
My environment:

WebKit r15196 downloaded from the project's website *not* built from source.
Stock install of WebKit/Safari with no plugins/manager/gadgets/anything
MacOS X 10.4.7
iBook G3/700
640MB RAM

What I did:

Copied a URL to the clipboard. Pick any webpage with a form with a textarea.  Type two parens "()" with no space between the two.  Position the cursor between the two parens with the intent of pasting the URL so it would be enclosed by the parens.  Paste the text using either the menu choice from the edit menu or the Cmd+v key combination.

What I expected:

I expected the URL to appear between the two parens.

What happens:

The text appears to the left of the parens.  This happens if the parens are typed "()" or ")(".

Notes:

It does not happen in the shipping version of Safari.  It happens with all text or symbol combinations.
Comment 1 Steve Kirks 2006-07-08 09:17:41 PDT
Created attachment 9270 [details]
A short screen movie of the bug's behavior in a text area
Comment 2 Steve Kirks 2006-07-08 09:18:59 PDT
Upload a screen movie of the bug's behavior.  Also, the bug is not limited to a specific website--pick any text area on any webpage.
Comment 3 David Kilzer (:ddkilzer) 2006-07-08 09:32:11 PDT

*** This bug has been marked as a duplicate of 9527 ***