Bug 96720 - [Chromium] Layout Test fast/forms/*-multiple-fields/*-multiple-fields-preserve-value-after-history-back.html is failing
Summary: [Chromium] Layout Test fast/forms/*-multiple-fields/*-multiple-fields-preserv...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: yosin
URL:
Keywords:
: 103152 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-13 20:15 PDT by Kent Tamura
Modified: 2012-12-05 00:50 PST (History)
6 users (show)

See Also:


Attachments
Patch (27.76 KB, patch)
2012-11-30 01:38 PST, Kent Tamura
no flags Details | Formatted Diff | Diff
Patch for landing (27.75 KB, patch)
2012-11-30 02:05 PST, Kent Tamura
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Tamura 2012-09-13 20:15:09 PDT
The following layout test is failing on Chromium-Mac and Chromium-Windows

fast/forms/time-multiple-fields/time-multiple-fields-preserve-value-after-history-back.html

Probable cause:

Unknown


http://test-results.appspot.com/dashboards/flakiness_dashboard.html#showExpectations=true&showLargeExpectations=true&tests=time-multiple-fields-preserve-value-after-history-back.html
Comment 1 Kent Tamura 2012-11-28 03:14:30 PST
*** Bug 103152 has been marked as a duplicate of this bug. ***
Comment 2 Kent Tamura 2012-11-28 03:16:12 PST
All of fast/forms/*-multiple-fields/*-multiple-fields-preserve-value-after-history-back.html are flaky.

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=preserve-value-after-history
Comment 3 Kent Tamura 2012-11-30 01:38:51 PST
Created attachment 176922 [details]
Patch
Comment 4 Kentaro Hara 2012-11-30 01:46:18 PST
Comment on attachment 176922 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=176922&action=review

> LayoutTests/ChangeLog:3
> +        [Chroimum] Layout Test fast/forms/*-multiple-fields/*-multiple-fields-preserve-value-after-history-back.html is failing

Typo: Chromium

> LayoutTests/ChangeLog:12
> +        Make the outer switch a function to be called window.onload, and stop to

>> Make the outer switch a function to be called window.onload

Is this necessary to fix the failure? (Why?) Or is this just a refactoring?
Comment 5 Kent Tamura 2012-11-30 01:54:12 PST
(In reply to comment #4)
> > LayoutTests/ChangeLog:12
> > +        Make the outer switch a function to be called window.onload, and stop to
> 
> >> Make the outer switch a function to be called window.onload
> 
> Is this necessary to fix the failure? (Why?) Or is this just a refactoring?

Yes.  ChangeLog explains the reason at the previous paragraph.
Comment 6 Kentaro Hara 2012-11-30 02:02:56 PST
Comment on attachment 176922 [details]
Patch

Makes sense. (I was misreading js-test-post.js with js-test-pre.js.)
Comment 7 Kent Tamura 2012-11-30 02:05:14 PST
Created attachment 176927 [details]
Patch for landing

Fix summary
Comment 8 WebKit Review Bot 2012-11-30 02:33:23 PST
Comment on attachment 176927 [details]
Patch for landing

Clearing flags on attachment: 176927

Committed r136219: <http://trac.webkit.org/changeset/136219>
Comment 9 WebKit Review Bot 2012-11-30 02:33:27 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Kent Tamura 2012-12-05 00:50:43 PST
r136219 fixed the major flakiness. However they still timed out and I marked them [ Slow ] in http://trac.webkit.org/changeset/136333 .  The slowness should be addressed in Bug 104094.