Bug 96438 - fast/spatial-navigation test fail on mac-wk2
Summary: fast/spatial-navigation test fail on mac-wk2
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar, MakingBotsRed
Depends on:
Blocks:
 
Reported: 2012-09-11 15:48 PDT by Stephanie Lewis
Modified: 2013-07-29 08:29 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.45 KB, patch)
2013-07-29 07:19 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stephanie Lewis 2012-09-11 15:48:20 PDT
After https://bugs.webkit.org/show_bug.cgi?id=96269 which implemented testRunner.setSpatialNavigationEnabled the fast/spatial-navigation tests are still failing on Mac WK2.
Comment 1 Radar WebKit Bug Importer 2012-09-11 15:49:02 PDT
<rdar://problem/12280331>
Comment 2 Tim Horton 2012-09-11 16:33:04 PDT
Related to https://bugs.webkit.org/show_bug.cgi?id=96226?
Comment 3 Stephanie Lewis 2012-09-11 16:34:35 PDT
Skipped in http://trac.webkit.org/changeset/128240
Comment 4 Jessie Berlin 2013-04-18 11:01:41 PDT
The spatial navigation tests all pass for me on Mountain Lion WK2 Debug. I think they were fixed by the fixes for https://bugs.webkit.org/show_bug.cgi?id=96226. I am going to unskip them.

*** This bug has been marked as a duplicate of bug 96226 ***
Comment 5 Jessie Berlin 2013-04-18 11:30:38 PDT
Nevermind, I was running wk1 tests by accident. Reopening.
Comment 6 Antoine Quint 2013-07-29 07:18:29 PDT
This test passes for me on 10.9, I can't tell if it passes on WK1 or Mountain Lion platforms as it stands, but I think we should be able to unskip it on Mac.
Comment 7 Antoine Quint 2013-07-29 07:19:37 PDT
Created attachment 207653 [details]
Patch
Comment 8 Antonio Gomes 2013-07-29 07:27:58 PDT
Comment on attachment 207653 [details]
Patch

It should pass since the switch to use Internals.
Comment 9 WebKit Commit Bot 2013-07-29 08:29:44 PDT
Comment on attachment 207653 [details]
Patch

Clearing flags on attachment: 207653

Committed r153425: <http://trac.webkit.org/changeset/153425>
Comment 10 WebKit Commit Bot 2013-07-29 08:29:48 PDT
All reviewed patches have been landed.  Closing bug.