Bug 94158 - calc isn't working with viewport units
: calc isn't working with viewport units
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: All All
: P2 Enhancement
Assigned To: Nobody
:
Depends on:
Blocks: 16662
  Show dependency treegraph
 
Reported: 2012-08-15 16:49 PDT by Alan Stearns
Modified: 2014-06-11 09:31 PDT (History)
12 users (show)

See Also:


Attachments
reftest (474 bytes, text/html)
2012-08-15 16:49 PDT, Alan Stearns
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Stearns 2012-08-15 16:49:16 PDT
Created attachment 158661 [details]
reftest

-webkit-calc is not evaluating vh/vw units
Comment 1 Mike Lawther 2012-12-03 22:09:56 PST
related: https://bugs.webkit.org/show_bug.cgi?id=91554. It looks like the original implementor of the vw/vh units in WebKit is not coming back to fix these issues.
Comment 2 Mike Lawther 2012-12-03 22:10:35 PST
*** Bug 103774 has been marked as a duplicate of this bug. ***
Comment 3 Chris Adams 2014-03-12 09:31:29 PDT
The Chrome team has reportedly fixed this in Blink:

https://code.google.com/p/chromium/issues/detail?id=168840
Comment 4 Maxime Goepp 2014-05-03 18:13:50 PDT
Any chance for a backport in the near future as this is a major issue for layout design ?
Comment 5 Bem Jones-Bey 2014-06-11 09:31:12 PDT
This has been fixed with the patch for Bug 87846.