Bug 93154 - REGRESSION(r124632): Added new WebFrameTest.SelectRange which fails on bots (Requested by dimich on #webkit).
Summary: REGRESSION(r124632): Added new WebFrameTest.SelectRange which fails on bots (...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 93108
  Show dependency treegraph
 
Reported: 2012-08-03 13:21 PDT by WebKit Review Bot
Modified: 2012-08-03 13:24 PDT (History)
2 users (show)

See Also:


Attachments
ROLLOUT of r124632 (5.36 KB, patch)
2012-08-03 13:22 PDT, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2012-08-03 13:21:58 PDT
http://trac.webkit.org/changeset/124632 broke the build:
Added new WebFrameTest.SelectRange which fails on bots (Requested by dimich on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-08-03 13:22:33 PDT
Created attachment 156445 [details]
ROLLOUT of r124632

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Dmitry Titov 2012-08-03 13:24:00 PDT
Comment on attachment 156445 [details]
ROLLOUT of r124632

Clearing flags on attachment: 156445

Committed r124646: <http://trac.webkit.org/changeset/124646>
Comment 3 Dmitry Titov 2012-08-03 13:24:03 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Dmitry Titov 2012-08-03 13:24:50 PDT
It reliably fails on Win Canary bots: http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Win/builds/16451/steps/webkit_unit_tests/logs/stdio

with this dump:
WebFrameTest.SelectRange: 
tests\WebFrameTest.cpp(818): error: Value of: std::string(frame->selectionAsText().utf8().data())
  Actual: "some test text for testin"
Expected: "some test text for testing"
tests\WebFrameTest.cpp(827): error: Value of: std::string(frame->selectionAsText().utf8().data())
  Actual: "some offscreen test text for testin"
Expected: "some offscreen test text for testing"