Bug 92192 - [Shadow DOM] descendant selector doesn't work across shadow boundaries.
Summary: [Shadow DOM] descendant selector doesn't work across shadow boundaries.
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: http://jsfiddle.net/ybyf4/
Keywords:
: 89169 (view as bug list)
Depends on:
Blocks: 59827 72352
  Show dependency treegraph
 
Reported: 2012-07-24 18:49 PDT by Hajime Morrita
Modified: 2013-01-07 23:24 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hajime Morrita 2012-07-24 18:49:06 PDT
If an ascent is in light DOM and descendant is in shadow, descendant selector doesn't work.
Comment 1 Hajime Morrita 2012-07-24 19:18:21 PDT
*** Bug 89169 has been marked as a duplicate of this bug. ***
Comment 2 Shinya Kawanaka 2012-07-24 22:36:50 PDT
I'm not sure this is a desired behavior. I believe this is sometimes useful though...
Comment 3 Dominic Cooney 2013-01-07 23:24:11 PST
The spec is quite specific on this point: <http://dvcs.w3.org/hg/webcomponents/raw-file/tip/spec/shadow/index.html#styles>

"Even when the apply-author-styles is set, the selectors still must not cross the shadow boundary per scoping constraints. In other words, with apply-author-styles set, the document CSS rules only match wholly inside or outside of the shadow tree."

This is the wrong forum for a spec bug; it should be taken up in the W3C.