Bug 91748 - [Blackberry][FullScreen] Create a helper method to adjust the fullscreen renderer dimensions
Summary: [Blackberry][FullScreen] Create a helper method to adjust the fullscreen rend...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit BlackBerry (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jacky Jiang
URL:
Keywords:
Depends on:
Blocks: 94601
  Show dependency treegraph
 
Reported: 2012-07-19 08:53 PDT by Antonio Gomes
Modified: 2013-01-08 14:11 PST (History)
7 users (show)

See Also:


Attachments
Patch (4.23 KB, patch)
2013-01-08 13:56 PST, Jacky Jiang
tonikitoo: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Gomes 2012-07-19 08:53:03 PDT
SSIA

https://bugzilla.qnx.com/bugzilla/show_bug.cgi?id=178237
Comment 1 Antonio Gomes 2013-01-08 12:06:33 PST
@Jacky,Max, was it upstreamed already? I barely remember a patch from Max for that.
Comment 2 Antonio Gomes 2013-01-08 12:08:32 PST
WebPagePrivate::adjustFullScreenElementDimensionsIfNeeded?
Comment 3 Antonio Gomes 2013-01-08 12:09:31 PST

*** This bug has been marked as a duplicate of bug 105488 ***
Comment 4 Jacky Jiang 2013-01-08 12:27:29 PST
(In reply to comment #1)
> @Jacky,Max, was it upstreamed already? I barely remember a patch from Max for that.
This hasn't been fully upstreamed,  since 105488 only upstreamed part of the fix.    I can do the rest.
Comment 5 Jacky Jiang 2013-01-08 13:56:27 PST
Created attachment 181751 [details]
Patch
Comment 6 Jacky Jiang 2013-01-08 14:11:11 PST
Committed r139110: <http://trac.webkit.org/changeset/139110>