Bug 91490 - [Qt][WK2] REGRESSION(r122770) - it made ~ 160 fails on WebKit2
Summary: [Qt][WK2] REGRESSION(r122770) - it made ~ 160 fails on WebKit2
Status: RESOLVED DUPLICATE of bug 88064
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 79666 91425
  Show dependency treegraph
 
Reported: 2012-07-17 04:01 PDT by János Badics
Modified: 2012-07-25 04:42 PDT (History)
11 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description János Badics 2012-07-17 04:01:50 PDT
156 tests fail on WebKit2 since r122768 or r122771.
Comment 1 Balazs Kelemen 2012-07-17 04:04:10 PDT
(In reply to comment #0)
> 156 tests fail on WebKit2 since r122768 or r122771.

... or any change in between the two.
Comment 2 Balazs Kelemen 2012-07-17 04:11:03 PDT
This is definitely not a jsc issue.
Comment 3 Allan Sandfeld Jensen 2012-07-17 05:21:41 PDT
r122769 is a rounding change (from floored int to rounded int for us), that could likely change metrics slightly all over the place.
Comment 4 Balazs Kelemen 2012-07-17 05:47:41 PDT
(In reply to comment #3)
> r122769 is a rounding change (from floored int to rounded int for us), that could likely change metrics slightly all over the place.

I rather suspect on r122770, I'm going to check these changes invidually (on 67).
Comment 5 Balazs Kelemen 2012-07-17 06:00:40 PDT
This is caused by r122770 (bisected).
Comment 6 Balazs Kelemen 2012-07-17 06:03:35 PDT
Link of results: http://build.webkit.sed.hu/results/x86-64%20Linux%20Qt%20Release%20WebKit2%20(Amazon%20EC2)/r122771%20(6073)/results.html (it refers to 71 because 67-70 did not build).
Comment 7 Eric Seidel (no email) 2012-07-17 10:37:25 PDT
http://trac.webkit.org/changeset/122770
Comment 8 Eric Seidel (no email) 2012-07-17 10:38:46 PDT
Links make it easy to see what the change in question was.  Also relating to the original bug may help get the attention of the authors of the original change, if that's your goal.
Comment 9 Simon Fraser (smfr) 2012-07-17 11:00:20 PDT
I find it hard to believe that r122770 caused those changes.
Comment 10 Balazs Kelemen 2012-07-18 02:14:29 PDT
(In reply to comment #8)
> Links make it easy to see what the change in question was.  Also relating to the original bug may help get the attention of the authors of the original change, if that's your goal.

Not for making a flame war of it but what is the rationale of blocking a resolved bug? I commented on that bug, I believe it should be enough to get the attention of the authors. Links are good idea, though :)
Comment 11 Csaba Osztrogonác 2012-07-25 04:42:44 PDT

*** This bug has been marked as a duplicate of bug 88064 ***