Bug 9114 - The file performance_test_results.html is missing after running atf
: The file performance_test_results.html is missing after running atf
Status: CLOSED FIXED
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 420+
: S60 Emulator S60 3rd edition
: P2 Normal
Assigned To: Pat
: EasyFix, PlatformOnly
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 12:03 PDT by David Bortone
Modified: 2006-07-28 10:59 PDT (History)
2 users (show)

See Also:


Attachments
Updates WebUI to run perf test when -autotest specified (13.49 KB, patch)
2006-05-26 15:02 PDT, Bradley Morrison
no flags Details | Formatted Diff | Diff
Runs performance tests when -autotest specified (24.84 KB, patch)
2006-05-30 13:41 PDT, Bradley Morrison
no flags Details | Formatted Diff | Diff
Added Changlog to previous patch (25.37 KB, patch)
2006-05-30 14:58 PDT, Bradley Morrison
zalan: review-
Details | Formatted Diff | Diff
Added Zalan's review changes to the patch (27.68 KB, patch)
2006-05-31 08:49 PDT, Pat
no flags Details | Formatted Diff | Diff
Adding changelog (28.23 KB, patch)
2006-05-31 09:24 PDT, Bradley Morrison
dacarson: review+
Details | Formatted Diff | Diff
Second pass at changes after review (AR2). Missed the typedef review comment. (28.38 KB, patch)
2006-05-31 10:42 PDT, Pat
zalan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Bortone 2006-05-25 12:03:30 PDT
The output from runatf is as follows:

Tested LayoutTests: 928
Failed LayoutTests: 0
Layout test results summary in X:/S60\LayoutTest_results.txt Performance results in X:/S60\performance_test_results.html

But there is no .html file, only the .txt
Comment 1 Bradley Morrison 2006-05-25 12:38:28 PDT
confirmed performance_test_results.html not copied to toplevel
Comment 2 Bradley Morrison 2006-05-26 15:02:47 PDT
Created attachment 8564 [details]
Updates WebUI to run perf test when -autotest specified
Comment 3 Bradley Morrison 2006-05-29 08:35:27 PDT
Patch causes reindeer to crash on startup. Reverting patch fixes reindeer startup crash, so r- for the moment. 
Comment 4 Bradley Morrison 2006-05-29 08:36:18 PDT
Comment on attachment 8564 [details]
Updates WebUI to run perf test when -autotest specified

Patch seems to crash reindeer at startup. Is it doing more than it needs to?
Comment 5 Bradley Morrison 2006-05-30 13:41:21 PDT
Created attachment 8607 [details]
Runs performance tests when -autotest specified
Comment 6 Bradley Morrison 2006-05-30 14:51:48 PDT
Comment on attachment 8564 [details]
Updates WebUI to run perf test when -autotest specified

r=me

Zalan, please review.
Comment 7 Bradley Morrison 2006-05-30 14:58:23 PDT
Created attachment 8609 [details]
Added Changlog to previous patch
Comment 8 zalan 2006-05-30 18:37:44 PDT
Comment on attachment 8609 [details]
Added Changlog to previous patch

>if ( !err && 
please check for err == KErrNone (symbian coding convetion)

>numTestsRun->Des().Length()
use numTestsRun->Length() instead. ->Des() creates a copy of that descriptor.

>PrepPerformanceResultsFileL()
cleanupCount variable is not needed.

>(TDesC&)KRunAllTests() 
change DoAutomatedTestsActionL signature from TDesC& aActionString to const TDesC& aActionString. no need for typecast.
Comment 9 Pat 2006-05-31 08:49:29 PDT
Created attachment 8624 [details]
Added Zalan's review changes to the patch

This patch contains the changes recommended by Zalan's review.
Comment 10 Bradley Morrison 2006-05-31 09:24:11 PDT
Created attachment 8625 [details]
Adding changelog
Comment 11 Bradley Morrison 2006-05-31 09:25:40 PDT
(In reply to comment #10)
> Created an attachment (id=8625) [edit]
> Adding changelog
> 

Please add changelog (see patch for details)
Also when adding a new patch, click the obsolete button on earlier patches
Please request review of patches by setting review flag to ? & entering email address
Comment 12 Pat 2006-05-31 10:42:12 PDT
Created attachment 8627 [details]
Second pass at changes after review (AR2). Missed the typedef review comment.

Added the typedef changes mentioned in the review.
Comment 13 Pat 2006-05-31 10:47:16 PDT
Comment on attachment 8627 [details]
Second pass at changes after review (AR2). Missed the typedef review comment.

Removed the typedefs in WebUiWindowContainer.cpp.  Where the call to DoAutomatedTestsActionL() is called.
Comment 14 zalan 2006-05-31 10:51:21 PDT
Comment on attachment 8627 [details]
Second pass at changes after review (AR2). Missed the typedef review comment.

r=me
looks great!
Comment 15 Bradley Morrison 2006-05-31 11:07:27 PDT
committed r14648 & setting to FIXED.

Thanks!
Comment 16 David Carson 2006-06-04 16:06:42 PDT
Comment on attachment 8625 [details]
Adding changelog

Marked the change log as review+ as the bug (and hopefully) the changlog has already been commited.
Comment 17 Timothy Hatcher 2006-06-26 06:34:24 PDT
Comment on attachment 8564 [details]
Updates WebUI to run perf test when -autotest specified

Clearing the review flag on this to remove it from the review queue, since this patch was obsoleted.
Comment 18 Krishna 2006-07-28 10:59:35 PDT
Set to CLOSED.