Bug 90459 - [REGRESSION] Crash when copying a StyleRuleMedia with a NULL m_mediaQueries
Summary: [REGRESSION] Crash when copying a StyleRuleMedia with a NULL m_mediaQueries
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexander Pavlov (apavlov)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-03 07:16 PDT by Alexander Pavlov (apavlov)
Modified: 2012-07-03 07:44 PDT (History)
5 users (show)

See Also:


Attachments
Patch (4.93 KB, patch)
2012-07-03 07:35 PDT, Alexander Pavlov (apavlov)
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pavlov (apavlov) 2012-07-03 07:16:14 PDT
Caused by http://trac.webkit.org/changeset/121551.
Patch to follow.
Comment 1 Alexander Pavlov (apavlov) 2012-07-03 07:35:07 PDT
Created attachment 150606 [details]
Patch
Comment 2 Andreas Kling 2012-07-03 07:41:28 PDT
Comment on attachment 150606 [details]
Patch

Looks legit. r=me
Comment 3 Alexander Pavlov (apavlov) 2012-07-03 07:44:36 PDT
Committed r121764: <http://trac.webkit.org/changeset/121764>