Bug 8991 - REGRESSION: missing or broken CSS custom cursors are displayed as a missing image icon
Summary: REGRESSION: missing or broken CSS custom cursors are displayed as a missing i...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Alexey Proskuryakov
URL: http://adresa.yandex.ru/search.xml?st...
Keywords: HasReduction, Regression
Depends on:
Blocks:
 
Reported: 2006-05-19 03:19 PDT by Alexey Proskuryakov
Modified: 2006-05-20 01:52 PDT (History)
0 users

See Also:


Attachments
test case (258 bytes, text/html)
2006-05-19 03:21 PDT, Alexey Proskuryakov
no flags Details
proposed fix (1.49 KB, patch)
2006-05-19 14:14 PDT, Alexey Proskuryakov
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2006-05-19 03:19:17 PDT
If a CSS custom cursor cannot be loaded, WebKit changes the cursor to a broken image icon. Since custom cursors aren't supported in shipping Safari, this causes regressions on some sites (e.g. bug URL, see bug 8989 for details).
Comment 1 Alexey Proskuryakov 2006-05-19 03:21:50 PDT
Created attachment 8402 [details]
test case
Comment 2 Alexey Proskuryakov 2006-05-19 14:14:39 PDT
Created attachment 8420 [details]
proposed fix

This fix doesn't honor the WinIE quirk of preserving the current cursor when entering an area with an invalid one.

I'm going to add more cases (bug 8988, bug 8989) to the manual test, thus I gave it such a generic name. I'm also filing a separate bug about fallback cursors.
Comment 3 Alexey Proskuryakov 2006-05-19 14:31:34 PDT
(In reply to comment #2)
>  I'm also filing a separate bug about fallback cursors.

Turns out there already was one, bug 6001.
Comment 4 Darin Adler 2006-05-19 18:43:14 PDT
Comment on attachment 8420 [details]
proposed fix

r=me
Comment 5 Alexey Proskuryakov 2006-05-20 01:52:58 PDT
Landed, r14501