Bug 89702 - [chromium] Layout test failures after fixing GraphicsLayerChromium scale factors
Summary: [chromium] Layout test failures after fixing GraphicsLayerChromium scale factors
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: vollick
URL:
Keywords:
Depends on: 89676
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 16:03 PDT by Kenneth Russell
Modified: 2013-04-09 17:06 PDT (History)
4 users (show)

See Also:


Attachments
TestExpectations update (1.49 KB, patch)
2012-06-21 16:33 PDT, Kenneth Russell
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2012-06-21 16:03:47 PDT
http://trac.webkit.org/changeset/120966 / https://bugs.webkit.org/show_bug.cgi?id=89676 has introduced at least a couple of layout test failures:

http://build.webkit.org/builders/Chromium%20Mac%20Release%20%28Tests%29/builds/18657

Regressions: Unexpected image mismatch : (2)
  compositing/geometry/fixed-position-transform-composited-page-scale-down.html = IMAGE
  compositing/scaling/tiled-layer-recursion.html = IMAGE

The failures are still percolating through the bots so I'm going to suppress them on all platforms via TestExpectations. compositing/geometry/fixed-position-transform-composited-page-scale-down.html looks like a progression; compositing/scaling/tiled-layer-recursion.html looks like a regression (the ends of the scrollbars are visible where they weren't before).
Comment 1 Kenneth Russell 2012-06-21 16:33:24 PDT
Created attachment 148911 [details]
TestExpectations update
Comment 2 Kenneth Russell 2012-06-21 16:40:47 PDT
Committed r120981: <http://trac.webkit.org/changeset/120981>
Comment 3 WebKit Review Bot 2012-07-27 05:03:24 PDT
Comment on attachment 148911 [details]
TestExpectations update

Cleared James Robinson's review+ from obsolete attachment 148911 [details] so that this bug does not appear in http://webkit.org/pending-commit.
Comment 4 Dana Jansens 2012-10-16 16:35:31 PDT
Rebased mac compositing/geometry/fixed-position-transform-composited-page-scale-down.html based on the comments here.

Committed r131527: <http://trac.webkit.org/changeset/131527>
Comment 5 Stephen Chenney 2013-04-09 17:06:28 PDT
Marked LayoutTest bugs, bugs with Chromium IDs, and some others as WontFix. Test failure bugs still are trackable via TestExpectations or disabled unit tests.