Bug 89443 - [Chromium] Web Inspector: remove unnecessary indirection from message loop instrumentation
Summary: [Chromium] Web Inspector: remove unnecessary indirection from message loop in...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Yury Semikhatsky
URL:
Keywords:
: 89361 (view as bug list)
Depends on: 88978
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 00:57 PDT by Yury Semikhatsky
Modified: 2012-06-19 06:14 PDT (History)
17 users (show)

See Also:


Attachments
Patch (8.56 KB, patch)
2012-06-19 01:00 PDT, Yury Semikhatsky
no flags Details | Formatted Diff | Diff
Patch (8.40 KB, patch)
2012-06-19 01:01 PDT, Yury Semikhatsky
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2012-06-19 00:57:57 PDT
No need to have start/stopMainThreadMonitoring on WebDevToolsAgentClient and WebDevToolsAgentImpl. The functionality may well be implemented inside InspectorClientImpl.
Comment 1 Yury Semikhatsky 2012-06-19 01:00:11 PDT
Created attachment 148276 [details]
Patch
Comment 2 Yury Semikhatsky 2012-06-19 01:01:34 PDT
Created attachment 148277 [details]
Patch
Comment 3 WebKit Review Bot 2012-06-19 01:03:10 PDT
Please wait for approval from abarth@webkit.org, dglazkov@chromium.org, fishd@chromium.org, jamesr@chromium.org or tkent@chromium.org before submitting, as this patch contains changes to the Chromium public API. See also https://trac.webkit.org/wiki/ChromiumWebKitAPI.
Comment 4 WebKit Review Bot 2012-06-19 03:28:00 PDT
Comment on attachment 148277 [details]
Patch

Clearing flags on attachment: 148277

Committed r120701: <http://trac.webkit.org/changeset/120701>
Comment 5 WebKit Review Bot 2012-06-19 03:28:05 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 eustas.bug 2012-06-19 06:14:55 PDT
*** Bug 89361 has been marked as a duplicate of this bug. ***