Bug 86516 - Add layout tests for OES_texture_float
Summary: Add layout tests for OES_texture_float
Status: RESOLVED DUPLICATE of bug 123188
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-15 13:16 PDT by Kenneth Russell
Modified: 2014-01-10 10:51 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2012-05-15 13:16:33 PDT
It was pointed out in Bug 85942 that layout tests are strongly needed in order to cover some code paths that are currently only tested on Chromium's GPU waterfall. Once the version of Mesa used in DRT is upgraded, we could plausibly integrate tests for the OES_texture_float extension that have previously not been run on the webkit.org bots. Unfortunately they would still need to be skipped on those ports which don't use Mesa in DRT, but at least some coverage would be possible.
Comment 1 Brent Fulgham 2014-01-10 10:51:43 PST
These tests are part of the Khronos suite, which is now part of our standard LayoutTest infrastructure.

*** This bug has been marked as a duplicate of bug 123188 ***