Bug 86484 - REGRESSION(r116712): This patch is causing crashes in Chromium Canary builds (Requested by pilgrim_google__ on #webkit).
Summary: REGRESSION(r116712): This patch is causing crashes in Chromium Canary builds ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 85221
  Show dependency treegraph
 
Reported: 2012-05-15 07:43 PDT by WebKit Review Bot
Modified: 2012-05-15 11:50 PDT (History)
2 users (show)

See Also:


Attachments
ROLLOUT of r116712 (41.24 KB, patch)
2012-05-15 07:44 PDT, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2012-05-15 07:43:27 PDT
http://trac.webkit.org/changeset/116712 broke the build:
This patch is causing crashes in Chromium Canary builds (Requested by pilgrim_google__ on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-05-15 07:44:14 PDT
Created attachment 141968 [details]
ROLLOUT of r116712

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Review Bot 2012-05-15 07:45:17 PDT
Comment on attachment 141968 [details]
ROLLOUT of r116712

Rejecting attachment 141968 [details] from commit-queue.

pilgrim@chromium.org does not have committer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 3 Adam Barth 2012-05-15 11:22:41 PDT
Comment on attachment 141968 [details]
ROLLOUT of r116712

Are you not in committers.py?  That should be easy to fix.
Comment 4 WebKit Review Bot 2012-05-15 11:47:02 PDT
Comment on attachment 141968 [details]
ROLLOUT of r116712

Clearing flags on attachment: 141968

Committed r117107: <http://trac.webkit.org/changeset/117107>
Comment 5 WebKit Review Bot 2012-05-15 11:47:07 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Michael Nordman 2012-05-15 11:50:12 PDT
bah... thnx for reverting