Bug 86372 - Web Inspector: [Styles] css properties copied into clipboard contain extra line breaks before color values
Summary: Web Inspector: [Styles] css properties copied into clipboard contain extra li...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Alexander Pavlov (apavlov)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-14 07:38 PDT by Alexander Pavlov (apavlov)
Modified: 2012-05-14 07:48 PDT (History)
10 users (show)

See Also:


Attachments
Patch (1.46 KB, patch)
2012-05-14 07:40 PDT, Alexander Pavlov (apavlov)
vsevik: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pavlov (apavlov) 2012-05-14 07:38:35 PDT
Copy property containing color into clipboard. See the extra line breaks.

This is caused by the "display: block" found in the ".swatch-inner" CSS class.

Upstreaming http://code.google.com/p/chromium/issues/detail?id=128008
Comment 1 Alexander Pavlov (apavlov) 2012-05-14 07:40:42 PDT
Created attachment 141726 [details]
Patch
Comment 2 Alexander Pavlov (apavlov) 2012-05-14 07:48:33 PDT
Committed r116946: <http://trac.webkit.org/changeset/116946>