Bug 85753 - [GTK] Split out FEATURE_DEFINES into a more easily autogenerated file
Summary: [GTK] Split out FEATURE_DEFINES into a more easily autogenerated file
Status: RESOLVED DUPLICATE of bug 87127
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 85611
  Show dependency treegraph
 
Reported: 2012-05-06 16:34 PDT by Eric Seidel (no email)
Modified: 2012-10-05 12:12 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2012-05-06 16:34:08 PDT
[GTK] Split out FEATURE_DEFINES into a more easily autogenerated file

Currently GTK seems to have code to support FEATURE_DEFINES in at least 3 places:
http://trac.webkit.org/browser/trunk/configure.ac
http://trac.webkit.org/browser/trunk/Source/WebCore/GNUmakefile.am
and of course:
http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitperl/FeatureList.pm

I've written a script as part of bug 85456 to generate all the various feature files across all ports, so that we have a single file which contributors can edit to add/remove an ENABLE_ macro from WebKit.  (Instead of the current situation, where they're added to a single port's build system, breaking all other ports or at least increasing fragmentation of what is "webkit" to website authors.)

I'm happy to generate the GTK code (since it looks pretty simple), but it needs to be broken out configure/GNUmakefile into simpler files, similar to what Qt did:
https://bugs.webkit.org/show_bug.cgi?id=85611

Obviously not the same syntax.  Any syntax is fine, I just can't generate the whole configure.ac or GNUmakefile.am from my script. :)

Thanks!  I'm happy to discuss this or other options on #webkit.
Comment 1 Zan Dobersek 2012-10-05 12:12:41 PDT
Done in bug #87127.

*** This bug has been marked as a duplicate of bug 87127 ***