Bug 85666 - [Mac] IETC flexbox reference tests have pixel differences (due to embedded color profiles?)
Summary: [Mac] IETC flexbox reference tests have pixel differences (due to embedded co...
Status: RESOLVED DUPLICATE of bug 85596
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P2 Normal
Assignee: Dave Tharp
URL:
Keywords: LayoutTestFailure, MakingBotsRed
Depends on: 85210
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 14:14 PDT by Andy Estes
Modified: 2012-05-07 14:21 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Estes 2012-05-04 14:14:02 PDT
14 IETC flexbox reference tests fail on the Mac bots (see <http://build.webkit.org/results/Lion%20Debug%20(Tests)/r116127%20(6209)/results.html>). Even though the test looks identical to the reference, ImageDiff thinks the colors painted by background-color differ from those in the reference images. This might be because the reference images embed an sRGB color profile.
Comment 1 Andy Estes 2012-05-04 14:18:25 PDT
Committed r116169: <http://trac.webkit.org/changeset/116169>
Comment 2 Tony Chang 2012-05-04 15:19:13 PDT
These appear to be ref tests, so there's no reference image or color profile.  Maybe something is weird in the test harness?  Most of the tests seem to be passing on Chromium.
Comment 3 Andy Estes 2012-05-04 15:24:13 PDT
(In reply to comment #2)
> These appear to be ref tests, so there's no reference image or color profile.  Maybe something is weird in the test harness?  Most of the tests seem to be passing on Chromium.

The reference .html file includes an image, and that image has a color profile.
Comment 4 Dave Tharp 2012-05-07 10:35:35 PDT
See comment on bug 85210.  Fix is coming :)
Comment 5 Dave Tharp 2012-05-07 14:21:31 PDT

*** This bug has been marked as a duplicate of bug 85596 ***