Bug 84997 - Delete dead code in Arena.h/cpp
: Delete dead code in Arena.h/cpp
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Ojan Vafai
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 13:32 PDT by Ojan Vafai
Modified: 2012-04-26 17:48 PDT (History)
4 users (show)

See Also:


Attachments
Patch (13.69 KB, patch)
2012-04-26 13:35 PDT, Ojan Vafai
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ojan Vafai 2012-04-26 13:32:57 PDT
Delete dead code in Arena.h/cpp
Comment 1 Ojan Vafai 2012-04-26 13:35:23 PDT
Created attachment 139057 [details]
Patch
Comment 2 WebKit Review Bot 2012-04-26 13:38:26 PDT
Attachment 139057 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/platform/Arena.h:77:  _a is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/Arena.h:78:  _nb is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/Arena.h:79:  _p is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/Arena.h:80:  _q is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/Arena.h:83:  Else clause should never be on same line as else (use 2 lines)  [whitespace/newline] [4]
Source/WebCore/platform/Arena.cpp:67:  j_ is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/Arena.cpp:105:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/WebCore/platform/Arena.cpp:119:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/WebCore/platform/Arena.cpp:119:  Use 0 instead of NULL.  [readability/null] [5]
Source/WebCore/platform/Arena.cpp:160:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/WebCore/platform/Arena.cpp:180:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Total errors found: 11 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Eric Seidel 2012-04-26 13:47:25 PDT
Comment on attachment 139057 [details]
Patch

OK.  You should use the cq to make sure nothing breaks.
Comment 4 WebKit Review Bot 2012-04-26 17:47:57 PDT
Comment on attachment 139057 [details]
Patch

Clearing flags on attachment: 139057

Committed r115389: <http://trac.webkit.org/changeset/115389>
Comment 5 WebKit Review Bot 2012-04-26 17:48:20 PDT
All reviewed patches have been landed.  Closing bug.