Bug 84329 - [CSS Regions] Content overflows horizontally when it should be clipped
Summary: [CSS Regions] Content overflows horizontally when it should be clipped
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 57312
  Show dependency treegraph
 
Reported: 2012-04-19 04:57 PDT by Razvan Caliman
Modified: 2013-01-02 13:55 PST (History)
6 users (show)

See Also:


Attachments
Test case (2.04 KB, text/html)
2012-04-19 04:57 PDT, Razvan Caliman
no flags Details
Bug screenshot (262.70 KB, image/tiff)
2012-04-19 04:58 PDT, Razvan Caliman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Razvan Caliman 2012-04-19 04:57:36 PDT
Created attachment 137878 [details]
Test case

Content overflows a region box horizontally when a line break is expected to occur, moving the content to the next line.
The issue stems from the margins of the content elements. Resetting the margins on the content seems to yield the expected result.
Comment 1 Razvan Caliman 2012-04-19 04:58:43 PDT
Created attachment 137879 [details]
Bug screenshot
Comment 2 Mihnea Ovidenie 2012-12-28 00:23:57 PST
Hi Razvan,

Please test it with the latest WebKit nightly, i cannot reproduce the issue anymore.

Thanks,
Comment 3 Zoltan Horvath 2013-01-02 13:55:52 PST
(In reply to comment #2)
> Hi Razvan,
> 
> Please test it with the latest WebKit nightly, i cannot reproduce the issue anymore.
> 
> Thanks,

Neither do I. I'm closing the bug.