Bug 84192 (inputTypeDateA11y) - input type=date datepicker not keyboard or VoiceOver accessible in Chrome Canary
Summary: input type=date datepicker not keyboard or VoiceOver accessible in Chrome Canary
Status: RESOLVED WONTFIX
Alias: inputTypeDateA11y
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.7
: P2 Major
Assignee: Nobody
URL: http://slides.html5rocks.com/#new-for...
Keywords:
Depends on: 84680
Blocks: 83852
  Show dependency treegraph
 
Reported: 2012-04-17 14:13 PDT by Paul J. Adam
Modified: 2013-05-08 16:03 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul J. Adam 2012-04-17 14:13:49 PDT
Chrome Version       : Version 20.0.1105.0 canary
URLs (if applicable) : http://slides.html5rocks.com/#new-form-types

What steps will reproduce the problem?
1. Visit http://slides.html5rocks.com/#new-form-types, enable VoiceOver if wanting to test screen reader accessibility
2. Tab to input type=date example
3. Attempt to activate date picker by pressing arrow keys, enter key, tab key, or next item VoiceOver gesture

What is the expected result?
Date picker should open and be navigable with the keyboard and usable for someone who is blind using VoiceOver.

What happens instead?
Nothing, it is not possible to activate the date picker with the keyboard or VoiceOver gestures. You have to use a mouse which is not accessible. Even if the mouse is used to activate the date picker the picker itself is still not accessible to VoiceOver.
Comment 1 Dominic Mazzoni 2012-05-01 22:15:52 PDT
It looks like the calendar control has some keyboard accessibility already, but a bug in Chrome is preventing VoiceOver from seeing the accessibility tree of the popup.

I filed http://crbug.com/125891

Once the Chrome bug is resolved, we can revisit this and see if the html/js needs any polishing to be fully accessible.

In the meantime I tried to check it in WebKit Nightly, but this feature doesn't seem to be enabled. Are there any plans to enable this in WebKit Nightly?
Comment 2 Kent Tamura 2012-05-01 22:23:18 PDT
(In reply to comment #1)
> In the meantime I tried to check it in WebKit Nightly, but this feature doesn't seem to be enabled. Are there any plans to enable this in WebKit Nightly?

For now, there are on plans to enable it in non-Chromium ports.  We need some platform-specific code like Source/WebKit/chromium/src/WebPagePopupImpl.cpp, but non-Chromium ports don't have it yet.
Comment 3 Kent Tamura 2012-05-01 22:23:52 PDT
(In reply to comment #2)
> For now, there are on plans
on plans -> no plans
Comment 4 Kent Tamura 2013-05-08 16:03:57 PDT
This is Chromium-only bug. We won't handle it in WebKit.