Bug 8409 - use of back button breaks scroll bar appearance in Safari. No longer updates it's appearance to reflect it's spot on the webpage.
Summary: use of back button breaks scroll bar appearance in Safari. No longer updates ...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 417.x
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.deliciousdays.com/
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-15 08:03 PDT by crastinator
Modified: 2008-02-17 22:14 PST (History)
3 users (show)

See Also:


Attachments
Example of glitchy scroll bar (10.17 KB, image/png)
2006-04-15 08:04 PDT, crastinator
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description crastinator 2006-04-15 08:03:09 PDT
There is something about the this site that causes the scroll bar to no longer update on it's position on the page. Here's the steps I take that seem to cause this.
1. Go to website 
2. I selected along the right side of the website, under the headiing 'categories' ; 'recipes : everyday' 
3. Selected a recipe, doesn't seem to matter which one.
4. Hit the back button using the keyboard shortcut. 
5. The page you come back to, starts illicting bug. You can scroll through the page using keybard, scroll bar, and scroll buttons, but the appearance of the scroll button no longer reflects where you are on the web page 

I've got the bug in both the 10.4.6 Safari and webkit build r13869.

Right now I'm writing this report on a window in front of the buggy webpage, it seems that if I switch between these 2 windows the appearance of the scroll bar will partially update itself. Though it will remember the previous positions of the scroll bar causing an odd graphical glitch.
Comment 1 crastinator 2006-04-15 08:04:34 PDT
Created attachment 7728 [details]
Example of glitchy scroll bar
Comment 2 Mark Rowe (bdash) 2006-07-06 19:00:57 PDT
I am unable to reproduce this bug with WebKit 418.8 and r15138 while following your instructions.  Are you still able to reproduce this bug?  Do you have any Safari extensions installed?
Comment 3 crastinator 2006-07-07 08:42:34 PDT
(In reply to comment #2)
> I am unable to reproduce this bug with WebKit 418.8 and r15138 while following
> your instructions.  Are you still able to reproduce this bug?  Do you have any
> Safari extensions installed?
> 

yup, I'm still getting it. I'm running latest shipping version of Safari webkit 418.8, Safari 2.04 (419.3). It's changed a bit in behavior I think. I can't really remember the exact details from last time but in this instance when i go back to the "recipes : everyday >> delicious days" page, and start scrolling down with page down, the slider will not move from it's original position at the top of the scroll bar, as I scroll down the page. However if I try dragging the slider it doesn't update it's position immediately but when I let go of the bar, the slider will suddenly appear at the spot where I let go of the slider but the slider's previous position will refuse to flush itself and remain there, causing the appearance of multiple broken up scroll sliders on the scroll bar.

I'm not running any plugins when I reported this bug. I'm not running any now,
Comment 4 Robert Blaut 2008-02-12 03:13:58 PST
I cannot confirm the bug. Reporter, is it still reproducible in your browser?
Comment 5 crastinator 2008-02-17 17:07:17 PST
(In reply to comment #4)
> I cannot confirm the bug. Reporter, is it still reproducible in your browser?
> 

No, it looks like it has went away.  The webpage itself has been changed since the initial report. I think you can close this. I am now on 10.5.2 using the latest stable Safari.