Bug 83427 - REGRESSION (r113233): fast/canvas/webgl/array-message-passing.html crashing on Lion and Snow Leopard bots
Summary: REGRESSION (r113233): fast/canvas/webgl/array-message-passing.html crashing o...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dmitry Lomov
URL: http://build.webkit.org/results/Lion%...
Keywords: InRadar, LayoutTestFailure, Regression
Depends on:
Blocks:
 
Reported: 2012-04-07 11:41 PDT by Jon Lee
Modified: 2012-04-12 12:17 PDT (History)
4 users (show)

See Also:


Attachments
Fix (3.12 KB, patch)
2012-04-10 16:20 PDT, Dmitry Lomov
dino: review+
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff
Amended patch (missed Reviewed by) (3.11 KB, patch)
2012-04-12 11:42 PDT, Dmitry Lomov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Lee 2012-04-07 11:41:17 PDT
The following test has been crashing on all Lion and Snow Leopard bots since r113233

    fast/canvas/webgl/array-message-passing.html

compare
http://build.webkit.org/old-results/Lion%20Release%20(Tests)/r113230%20%287263%29.zip
http://build.webkit.org/old-results/Lion%20Release%20(Tests)/r113233%20%287264%29.zip

Currently being skipped on bots.
Comment 1 Radar WebKit Bug Importer 2012-04-07 11:41:41 PDT
<rdar://problem/11206515>
Comment 2 Dmitry Lomov 2012-04-10 16:20:55 PDT
Created attachment 136567 [details]
Fix

Ooops, apologies, the bug was caused by an incorrect rebase. Here is the fix.
Comment 3 WebKit Review Bot 2012-04-10 20:36:52 PDT
Comment on attachment 136567 [details]
Fix

Rejecting attachment 136567 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 1

ERROR: /mnt/git/webkit-commit-queue/LayoutTests/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).

Full output: http://queues.webkit.org/results/12384592
Comment 4 Dmitry Lomov 2012-04-12 11:42:04 PDT
Created attachment 136943 [details]
Amended patch (missed Reviewed by)
Comment 5 WebKit Review Bot 2012-04-12 12:17:06 PDT
Comment on attachment 136943 [details]
Amended patch (missed Reviewed by)

Clearing flags on attachment: 136943

Committed r114013: <http://trac.webkit.org/changeset/114013>
Comment 6 WebKit Review Bot 2012-04-12 12:17:10 PDT
All reviewed patches have been landed.  Closing bug.