Bug 8283 - REGRESSION: File's path doesn't appear after dragging file into input field
Summary: REGRESSION: File's path doesn't appear after dragging file into input field
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-04-09 19:24 PDT by Chris Petersen
Modified: 2006-04-21 01:28 PDT (History)
1 user (show)

See Also:


Attachments
Sample input field (166 bytes, text/html)
2006-04-09 19:25 PDT, Chris Petersen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petersen 2006-04-09 19:24:11 PDT
After I drag n drop a image file to a input field, the file path doesn't appear in the field. However, the Edit menu does indicate the drag was successful since the Edit menu shows "Undo Paste"

Note: I'm only able to reproduce this image (GIF, JPEG, PNG, TIFF) or PDF files.

STEPS TO REPRODUCE
1. With TOT Webkit , open test case "sample_input.html"
2. Drag a image file so that is hovers over the input field. Notice you should see a caret as you hover over the input field. When this occurs, mouse up.
3. Instead of displaying the file's path in the field, nothing is displayed.

RESULTS
File path for image file should be displayed in the field. Instead, no file path is displayed.

REGRESSION
Yes, the only occurs with native text fields.
Comment 1 Chris Petersen 2006-04-09 19:25:34 PDT
Created attachment 7608 [details]
Sample input field
Comment 2 Chris Petersen 2006-04-09 19:28:02 PDT
This has been filed as <rdar://problem/4507837>
Comment 3 mitz 2006-04-09 22:17:36 PDT
See also bug 8276.
Comment 4 mitz 2006-04-10 06:39:44 PDT
For non-image items, the paste result is incorrect as well: instead of the file path, a file: URL is being pasted.
Comment 5 Adele Peterson 2006-04-10 13:55:00 PDT
While this is a native text field regression, we think the symptom is mild, so
we're moving it to P2.