Bug 82537 - REGRESSION(r110064): The patch leaks the DOM when audio elements are used (Requested by sundiamonde on #webkit).
Summary: REGRESSION(r110064): The patch leaks the DOM when audio elements are used (Re...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 72698
  Show dependency treegraph
 
Reported: 2012-03-28 15:06 PDT by WebKit Review Bot
Modified: 2012-03-28 18:03 PDT (History)
3 users (show)

See Also:


Attachments
ROLLOUT of r110064 (2.92 KB, patch)
2012-03-28 15:07 PDT, WebKit Review Bot
slewis: review+
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2012-03-28 15:06:52 PDT
http://trac.webkit.org/changeset/110064 broke the build:
The patch leaks the DOM when audio elements are used (Requested by sundiamonde on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-03-28 15:07:37 PDT
Created attachment 134411 [details]
ROLLOUT of r110064

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Review Bot 2012-03-28 15:26:37 PDT
Comment on attachment 134411 [details]
ROLLOUT of r110064

Rejecting attachment 134411 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
m'

________ running '/usr/bin/python gyp_webkit' in '/mnt/git/webkit-commit-queue/Source/WebKit/chromium'
Updating webkit projects from gyp files...
LayoutTests/platform/gtk/test_expectations.txt:79:  More specific entry on line 79 overrides line 12 http/tests/security/cross-origin-xsl-redirect-BLOCKED.html  [test/expectations] [5]
LayoutTests/platform/gtk/test_expectations.txt:108:  Path does not exist. css3/flexbox/inline-flexbox.html  [test/expectations] [5]
Total errors found: 2 in 1 files

Full output: http://queues.webkit.org/results/12097123
Comment 3 Stephanie Lewis 2012-03-28 18:03:43 PDT
Rolled out in http://trac.webkit.org/projects/webkit/changeset/112483

I reopened the original bug for doing the correct fix. (https://bugs.webkit.org/show_bug.cgi?id=72698)