Bug 81793 - Layout Test svg/as-image/animated-svg-as-image.html is crashing
Summary: Layout Test svg/as-image/animated-svg-as-image.html is crashing
Status: RESOLVED DUPLICATE of bug 82232
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Takashi Toyoshima
URL: http://test-results.appspot.com/dashb...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-21 09:42 PDT by Emil A Eklund
Modified: 2012-04-07 07:08 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emil A Eklund 2012-03-21 09:42:10 PDT
The following layout test is failing on Webkit Mac10.6 (dbg)

svg/as-image/animated-svg-as-image.html

Probable cause:

Assertion, ASSERTION FAILED: !needsLayout()

2012-03-21 08:38:29,907 1065 single_test_runner.py:203 DEBUG worker/6 svg/as-image/animated-svg-as-image.html crashed, stack trace:
2012-03-21 08:38:29,907 1065 single_test_runner.py:209 DEBUG   ASSERTION FAILED: !needsLayout()
2012-03-21 08:38:29,907 1065 single_test_runner.py:209 DEBUG   /b/build/slave/webkit-mac-latest-dbg/build/src/third_party/WebKit/Source/WebCore/WebCore.gyp/../page/FrameView.cpp(2958) : virtual void WebCore::FrameView::paintContents(WebCore::GraphicsContext *, const WebCore::IntRect &)
2012-03-21 08:38:29,907 1065 single_test_runner.py:209 DEBUG   1   0x18995bba WebCore::FrameView::paintContents(WebCore::GraphicsContext*, WebCore::IntRect const&)
2012-03-21 08:38:29,907 1065 single_test_runner.py:209 DEBUG   2   0x17c4b20c WebCore::ScrollView::paint(WebCore::GraphicsContext*, WebCore::IntRect const&)
2012-03-21 08:38:29,907 1065 single_test_runner.py:209 DEBUG   3   0x19475b53 WebCore::SVGImage::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator)
2012-03-21 08:38:29,907 1065 single_test_runner.py:209 DEBUG   4   0x1947559e WebCore::SVGImage::drawSVGToImageBuffer(WebCore::ImageBuffer*, WebCore::IntSize const&, float, WebCore::SVGImage::ShouldClearBuffer)
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   5   0x1946b2dd WebCore::SVGImageCache::redraw()
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   6   0x1946b0e5 WebCore::SVGImageCache::imageContentChanged()
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   7   0x188c692b WebCore::CachedImage::changedInRect(WebCore::Image const*, WebCore::IntRect const&)
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   8   0x188c69a6 non-virtual thunk to WebCore::CachedImage::changedInRect(WebCore::Image const*, WebCore::IntRect const&)
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   9   0x1947aea5 WebCore::SVGImageChromeClient::invalidateContentsAndRootView(WebCore::IntRect const&, bool)
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   10  0x1890c2ee WebCore::Chrome::invalidateContentsAndRootView(WebCore::IntRect const&, bool)
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   11  0x17c4a3be WebCore::ScrollView::repaintContentRectangle(WebCore::IntRect const&, bool)
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   12  0x18991d99 WebCore::FrameView::doDeferredRepaints()
2012-03-21 08:38:29,908 1065 single_test_runner.py:209 DEBUG   13  0x1898def2 WebCore::FrameView::endDeferredRepaints()
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   14  0x1898c7d7 WebCore::FrameView::layout(bool)
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   15  0x18987dc2 WebCore::FrameView::layoutTimerFired(WebCore::Timer<WebCore::FrameView>*)
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   16  0x189aa357 WebCore::Timer<WebCore::FrameView>::fired()
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   17  0x17c611de WebCore::ThreadTimers::sharedTimerFiredInternal()
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   18  0x17c60f6f WebCore::ThreadTimers::sharedTimerFired()
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   19  0x19853739 webkit_glue::WebKitPlatformSupportImpl::DoTimeout()
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   20  0x198542e7 base::BaseTimer<webkit_glue::WebKitPlatformSupportImpl, false>::TimerTask::Run()
2012-03-21 08:38:29,909 1065 single_test_runner.py:209 DEBUG   21  0x164b6c64 base::internal::RunnableAdapter<void (base::BaseTimer_Helper::TimerTask::*)()>::Run(base::BaseTimer_Helper::TimerTask*)
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   22  0x164b6b63 base::internal::InvokeHelper<false, void, base::internal::RunnableAdapter<void (base::BaseTimer_Helper::TimerTask::*)()>, void ()(base::BaseTimer_Helper::TimerTask*)>::MakeItSo(base::internal::RunnableAdapter<void (base::BaseTimer_Helper::TimerTask::*)()>, base::BaseTimer_Helper::TimerTask*)
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   23  0x164b6a9e base::internal::Invoker<1, base::internal::BindState<base::internal::RunnableAdapter<void (base::BaseTimer_Helper::TimerTask::*)()>, void ()(base::BaseTimer_Helper::TimerTask*), void ()(base::internal::OwnedWrapper<base::BaseTimer_Helper::TimerTask>)>, void ()(base::BaseTimer_Helper::TimerTask*)>::Run(base::internal::BindStateBase*)
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   24  0x1640869b base::Callback<void ()()>::Run() const
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   25  0x16405dbe MessageLoop::RunTask(base::PendingTask const&)
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   26  0x16406161 MessageLoop::DeferOrRunPendingTask(base::PendingTask const&)
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   27  0x16406398 MessageLoop::DoWork()
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   28  0x16376d6b base::MessagePumpCFRunLoopBase::RunWork()
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   29  0x16376462 base::MessagePumpCFRunLoopBase::RunWorkSource(void*)
2012-03-21 08:38:29,910 1065 single_test_runner.py:209 DEBUG   30  0x91d8942b __CFRunLoopDoSources0
2012-03-21 08:38:29,911 1065 single_test_runner.py:209 DEBUG   31  0x91d86eef __CFRunLoopRun


Likely caused by change 111537 <http://trac.webkit.org/changeset/111537>
Comment 1 Nikolas Zimmermann 2012-04-07 01:31:20 PDT
Is this fixed now by stephens last patch?
Comment 2 Stephen Chenney 2012-04-07 07:08:54 PDT
Marking as dupe.

*** This bug has been marked as a duplicate of bug 82232 ***