Bug 8158 - REGRESSION: Clicking past RTL text in a new text field puts the caret on the wrong side of the text
Summary: REGRESSION: Clicking past RTL text in a new text field puts the caret on the ...
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2006-04-03 10:31 PDT by mitz
Modified: 2006-04-07 12:16 PDT (History)
0 users

See Also:


Attachments
Test case (548 bytes, text/html)
2006-04-03 10:32 PDT, mitz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-04-03 10:31:32 PDT
Clicking to the left (resp. right) or RTL text puts the caret to the right (resp. left) of the text. The caret should be positioned at the edge of the text which is closer to the click position. See the attached test case.
Comment 1 mitz 2006-04-03 10:32:07 PDT
Created attachment 7484 [details]
Test case
Comment 2 Adele Peterson 2006-04-04 11:06:07 PDT
this is also reproducible with contenteditable divs.
Comment 3 Adele Peterson 2006-04-04 11:23:30 PDT
I'm pretty sure the problem is in RenderText::positionForCoordinates
Comment 4 Adele Peterson 2006-04-04 16:16:00 PDT
I have a fix for this... just working on a test now.
Comment 5 mitz 2006-04-07 12:16:49 PDT
Verified in r13271 nightly. I think this fix is even more important for Mail!