With reference to the comments from Hayato in bug https://bugs.webkit.org/show_bug.cgi?id=81102,
"We should rename getElementInShadowTreeStack since it can return ShadowRoot, which is not Element.
That is an unintentional usage that it can return ShadowRoot. So we should rename it to getNodeInShadowTreeStack."
Created attachment 132790 [details]
Okay. You need r+ from reviewers.
(In reply to comment #1)
> Created an attachment (id=132790) [details]
Comment on attachment 132790 [details]
Clearing flags on attachment: 132790
Committed r111505: <http://trac.webkit.org/changeset/111505>
All reviewed patches have been landed. Closing bug.