Bug 8092 - REGRESSION (NativeTextField): table contents misaligned in Netflix queue
Summary: REGRESSION (NativeTextField): table contents misaligned in Netflix queue
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL: http://www.netflix.com/Queue
Keywords: HasReduction, InRadar, Regression
: 7892 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-30 14:45 PST by John Sullivan
Modified: 2006-04-04 15:19 PDT (History)
2 users (show)

See Also:


Attachments
Picture showing misalignment of all columns past the initial text field. (23.24 KB, image/png)
2006-03-30 14:46 PST, John Sullivan
no flags Details
Reduced test case from expedia (766 bytes, text/html)
2006-04-02 00:08 PST, Chris Petersen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Sullivan 2006-03-30 14:45:00 PST
This bug is also in Radar as <rdar://4496831>

To reproduce:

1. log in to netflix (requires account)
2. click Queue tab

The data in the columns (other than the first column) is pushed over to the right. See attached picture. I think this started in the last few days.

-------------------------------------------

Here's a reduction. It seems to be an interaction of the new text fields with table layout:

<table><tr><td style="background-color:red;"><input style="width:20px;"></td></tr></table>

In released Safaris, the table cell neatly encloses the text field. In tip of tree, the table cell is much wider than the text field. It looks like the enclosing table cell is sized based on the default width of an input element, rather than the specified width of this particular input element.
Comment 1 John Sullivan 2006-03-30 14:46:07 PST
Created attachment 7406 [details]
Picture showing misalignment of all columns past the initial text field.
Comment 2 mitz 2006-03-31 00:26:00 PST
*** Bug 7892 has been marked as a duplicate of this bug. ***
Comment 3 Chris Petersen 2006-04-02 00:07:15 PST
I ran into this same issue at http://www.expedia.com/ where input element was forcing a select element to wrap down to a new line in the containing DIV. I reduced the page down and was about file this in a new bugzilla bug but then noticed this one.

In any case adding my reduced test case to this report . Notice the border of the native text field is rendered at the default size even though it's been specifed as  "style="width:10px".
Comment 4 Chris Petersen 2006-04-02 00:08:08 PST
Created attachment 7457 [details]
Reduced test case from expedia
Comment 5 Maciej Stachowiak 2006-04-02 23:25:40 PDT
These are all text field regressions so they should all be P1.
Comment 6 Adele Peterson 2006-04-03 18:27:53 PDT
I'm working on fixing calcMinMaxWidth, which will fix this bug.