Bug 79029 - [Qt] REGRESSION(r108112): sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.2_decodeURIComponent/S15.1.3.2_A1.2_T2.html crashes intermittently
Summary: [Qt] REGRESSION(r108112): sputnik/Conformance/15_Native_Objects/15.1_The_Glob...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Critical
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks: 66994 79666 79668
  Show dependency treegraph
 
Reported: 2012-02-20 06:29 PST by Csaba Osztrogonác
Modified: 2012-05-17 05:24 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2012-02-20 06:29:00 PST
sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.2_decodeURIComponent/S15.1.3.2_A1.2_T2.html
crashes intermittently on Qt on 64 bit release mode with the following crash log:

1   0x422a08 /home/oszi/WebKit/WebKitBuild/Release/bin/DumpRenderTree() [0x422a08]
2   0x7f0290a1e1e0 /lib/libc.so.6(+0x321e0) [0x7f0290a1e1e0]
3   0x7f029850da97 /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::SlotVisitor::drain()+0xc7) [0x7f029850da97]
4   0x7f029850a086 /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::Heap::markRoots(bool)+0x186) [0x7f029850a086]
5   0x7f029850a54d /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::Heap::collect(JSC::Heap::SweepToggle)+0x1d) [0x7f029850a54d]
6   0x7f02985105f2 /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::MarkedAllocator::allocateSlowCase()+0x9b2) [0x7f02985105f2]
7   0x7f029868584d /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::addErrorInfo(JSC::JSGlobalData*, JSC::JSObject*, int, JSC::SourceCode const&, WTF::Vector<JSC::StackFrame, 0ul> const&)+0xcdd) [0x7f029868584d]
8   0x7f029859011d /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::Interpreter::throwException(JSC::ExecState*&, JSC::JSValue&, unsigned int)+0x2ed) [0x7f029859011d]
9   0x7f02985b0823 /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::genericThrow(JSC::JSGlobalData*, JSC::ExecState*, JSC::JSValue, unsigned int)+0x33) [0x7f02985b0823]
10  0x7f02985b0912 /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(JSC::jitThrow(JSC::JSGlobalData*, JSC::ExecState*, JSC::JSValue, JSC::ReturnAddressPtr)+0x82) [0x7f02985b0912]
11  0x7f02985ca803 /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(cti_vm_throw+0x23) [0x7f02985ca803]
12  0x7f02985ca600 /home/oszi/WebKit/WebKitBuild/Release/lib/libQtWebKit.so.4(+0x1cb9600) [0x7f02985ca600]

I'm going to find which revision caused this crash.
Comment 1 Csaba Osztrogonác 2012-02-20 10:49:36 PST
This crash occures from r108112, I got it with manual bisecting.

Zoltán, Gábor, could you check this annoying regression?
Comment 2 Csaba Osztrogonác 2012-02-20 10:50:07 PST
You can easily reproduce it with:
$ Tools/Scripts/old-run-webkit-tests --iterations 1000 sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.2_decodeURIComponent/S15.1.3.2_A1.2_T2.html --exit-after-n-crashes 1
Comment 3 Csaba Osztrogonác 2012-02-21 04:39:56 PST
I skipped it to make buildbot happier - http://trac.webkit.org/changeset/108342 (and make it able to catch new regression) 

But it seems to be a serious regression, because crashes are always serious.

Is there any volunteer interested in fixing this new crash?
Comment 4 Csaba Osztrogonác 2012-02-21 08:55:35 PST
more tests crash because of this bug:
- sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.2_decodeURIComponent/S15.1.3.2_A1.2_T1.html
- sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.1_decodeURI/S15.1.3.1_A1.2_T1.html

Is there a JSC expert volunteer to fix it? Or these crashes aren't bug, but feature? :)
Comment 5 Oliver Hunt 2012-02-21 11:11:13 PST
(In reply to comment #4)
> more tests crash because of this bug:
> - sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.2_decodeURIComponent/S15.1.3.2_A1.2_T1.html
> - sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.1_decodeURI/S15.1.3.1_A1.2_T1.html
> 
> Is there a JSC expert volunteer to fix it? Or these crashes aren't bug, but feature? :)

It's a performance enhancement, we run to completion much faster now!
Comment 6 Csaba Osztrogonác 2012-02-22 08:27:34 PST
new crashing tests because of this regression:
- sputnik/Unicode/Unicode_218/S7.6_A5.3_T2.html
- sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.1_decodeURI/S15.1.3.1_A1.12_T1.html
Comment 7 Oliver Hunt 2012-02-22 09:40:21 PST
(In reply to comment #6)
> new crashing tests because of this regression:
> - sputnik/Unicode/Unicode_218/S7.6_A5.3_T2.html
> - sputnik/Conformance/15_Native_Objects/15.1_The_Global_Object/15.1.3/15.1.3.1_decodeURI/S15.1.3.1_A1.12_T1.html

Wha, this was error.stack bustage? gah!

Can someone see if we trigger any assertion failures in debug builds?
Comment 8 Csaba Osztrogonác 2012-02-27 05:20:59 PST
One more crash because of this bug: (fast/forms/form-associated-element-crash.html)
1   0x422a48 /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x422a48]
2   0x7f29a10e3ff0 /lib/libpthread.so.0(+0xeff0) [0x7f29a10e3ff0]
3   0x7f29a7ba8156 /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC11SlotVisitor5drainEv+0x1a6) [0x7f29a7ba8156]
4   0x7f29a7ba529c /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap9markRootsEb+0x31c) [0x7f29a7ba529c]
5   0x7f29a7ba55fd /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap7collectENS0_11SweepToggleE+0x1d) [0x7f29a7ba55fd]
6   0x7f29a6cb1ba5 /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(+0xd10ba5) [0x7f29a6cb1ba5]
7   0x7f29a72fc3a6 /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore12ThreadTimers24sharedTimerFiredInternalEv+0xa6) [0x7f29a72fc3a6]
8   0x7f29a171f519 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0xa9) [0x7f29a171f519]
9   0x7f29a1fdb19c /usr/local/Trolltech/Qt-4.8.0/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac) [0x7f29a1fdb19c]
10  0x7f29a1fe206d /usr/local/Trolltech/Qt-4.8.0/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x13d) [0x7f29a1fe206d]
11  0x7f29a170d0ec /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x8c) [0x7f29a170d0ec]
12  0x7f29a174152e /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(+0x1cf52e) [0x7f29a174152e]
13  0x7f29a173e47d /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(+0x1cc47d) [0x7f29a173e47d]
14  0x7f29a39596f2 /lib/libglib-2.0.so.0(g_main_context_dispatch+0x1f2) [0x7f29a39596f2]
15  0x7f29a395d568 /lib/libglib-2.0.so.0(+0x42568) [0x7f29a395d568]
16  0x7f29a395d71c /lib/libglib-2.0.so.0(g_main_context_iteration+0x6c) [0x7f29a395d71c]
17  0x7f29a173e163 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x73) [0x7f29a173e163]
18  0x7f29a2087a9e /usr/local/Trolltech/Qt-4.8.0/lib/libQtGui.so.4(+0x2c2a9e) [0x7f29a2087a9e]
19  0x7f29a170bca2 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x32) [0x7f29a170bca2]
20  0x7f29a170c114 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x164) [0x7f29a170c114]
21  0x7f29a1711d19 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN16QCoreApplication4execEv+0xb9) [0x7f29a1711d19]
22  0x423b7e /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x423b7e]
23  0x7f29a0098c8d /lib/libc.so.6(__libc_start_main+0xfd) [0x7f29a0098c8d]
24  0x40ff09 /ramdisk/qt-linux-64-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x40ff09]
Comment 9 Csaba Osztrogonác 2012-02-27 07:43:44 PST
One more crash:

1   0x8066e5b /ramdisk/qt-linux-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x8066e5b]
2   0xf7733400 [0xf7733400]
3   0xf6d9992d /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC11SlotVisitor5drainEv+0x18d) [0xf6d9992d]
4   0xf6d967a4 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap9markRootsEb+0x3a4) [0xf6d967a4]
5   0xf6d96b6e /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap7collectENS0_11SweepToggleE+0x2e) [0xf6d96b6e]
6   0xf6d96c43 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap17collectAllGarbageEv+0x43) [0xf6d96c43]
7   0xf5dd01f4 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(+0x95d1f4) [0xf5dd01f4]
8   0xf5dd0131 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore5TimerINS_12GCControllerEE5firedEv+0x21) [0xf5dd0131]
9   0xf645caf9 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore12ThreadTimers24sharedTimerFiredInternalEv+0xa9) [0xf645caf9]
10  0xf645cbd5 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore12ThreadTimers16sharedTimerFiredEv+0x45) [0xf645cbd5]
11  0xf6651d36 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore13SharedTimerQt10timerEventEP11QTimerEvent+0x46) [0xf6651d36]
12  0xf3b474e4 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x84) [0xf3b474e4]
13  0xf3f50e0c /usr/local/Trolltech/Qt-4.8.0/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac) [0xf3f50e0c]
14  0xf3f56cc2 /usr/local/Trolltech/Qt-4.8.0/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x162) [0xf3f56cc2]
15  0xf3b341ab /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x7b) [0xf3b341ab]
16  0xf3b6ab87 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(+0x1c5b87) [0xf3b6ab87]
17  0xf3b67b6a /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(+0x1c2b6a) [0xf3b67b6a]
18  0xf4ed2305 /lib/libglib-2.0.so.0(g_main_context_dispatch+0x1d5) [0xf4ed2305]
19  0xf4ed5fe8 /lib/libglib-2.0.so.0(+0x3efe8) [0xf4ed5fe8]
20  0xf4ed61c8 /lib/libglib-2.0.so.0(g_main_context_iteration+0x68) [0xf4ed61c8]
21  0xf3b67855 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x65) [0xf3b67855]
22  0xf400b775 /usr/local/Trolltech/Qt-4.8.0/lib/libQtGui.so.4(+0x229775) [0xf400b775]
23  0xf3b32a69 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x49) [0xf3b32a69]
24  0xf3b32f72 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x182) [0xf3b32f72]
25  0xf3b3932f /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN16QCoreApplication4execEv+0xaf) [0xf3b3932f]
26  0xf3f4fe77 /usr/local/Trolltech/Qt-4.8.0/lib/libQtGui.so.4(_ZN12QApplication4execEv+0x27) [0xf3f4fe77]
27  0x8067f11 /ramdisk/qt-linux-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x8067f11]
28  0xf3592c96 /lib/libc.so.6(__libc_start_main+0xe6) [0xf3592c96]
29  0x80547d1 /ramdisk/qt-linux-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x80547d1]
Comment 10 Oliver Hunt 2012-02-27 08:11:23 PST
Could you please add information that is useful?  backtrace with line numbers for instance.
Comment 11 Csaba Osztrogonác 2012-02-27 08:15:21 PST
(In reply to comment #10)
> Could you please add information that is useful?  backtrace with line numbers for instance.

Unfortunately I can't, because bots usually catch these crashes in release mode.
I'm going to reproduce crashes locally in debug mode.
Comment 12 Csaba Osztrogonác 2012-03-05 03:07:51 PST
One more crash: ( http://build.webkit.org/results/Qt%20Linux%20Release/r109729%20%2844012%29/http/tests/inspector/inspect-iframe-from-different-domain-crash-log.txt )
1   0x8066e5b /ramdisk/qt-linux-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x8066e5b]
2   0xf76ee400 [0xf76ee400]
3   0xf6d4ca87 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC11SlotVisitor5drainEv+0x97) [0xf6d4ca87]
4   0xf6d4cdd9 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC11SlotVisitor15drainFromSharedENS0_15SharedDrainModeE+0xf9) [0xf6d4cdd9]
5   0xf6d4de3c /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC25MarkStackThreadSharedData17markingThreadMainEv+0x7c) [0xf6d4de3c]
6   0xf6d4dead /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC25MarkStackThreadSharedData22markingThreadStartFuncEPv+0x1d) [0xf6d4dead]
7   0xf6fa940f /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(+0x1b9e40f) [0xf6fa940f]
8   0xf6fbf47e /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(+0x1bb447e) [0xf6fbf47e]
9   0xf38c47b0 /lib/libpthread.so.0(+0x57b0) [0xf38c47b0]
10  0xf35e00be /lib/libc.so.6(clone+0x5e) [0xf35e00be]
1   0x8066e5b /ramdisk/qt-linux-release/build/WebKitBuild/Release/bin/DumpRenderTree() [0x8066e5b]
2   0xf76ee400 [0xf76ee400]
3   0xf6d4ca87 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC11SlotVisitor5drainEv+0x97) [0xf6d4ca87]
4   0xf6d499f4 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap9markRootsEb+0x3a4) [0xf6d499f4]
5   0xf6d49dbe /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap7collectENS0_11SweepToggleE+0x2e) [0xf6d49dbe]
6   0xf6d49e93 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap17collectAllGarbageEv+0x43) [0xf6d49e93]
7   0xf5d74194 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(+0x969194) [0xf5d74194]
8   0xf5d740d1 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore5TimerINS_12GCControllerEE5firedEv+0x21) [0xf5d740d1]
9   0xf640a889 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore12ThreadTimers24sharedTimerFiredInternalEv+0xa9) [0xf640a889]
10  0xf640a965 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore12ThreadTimers16sharedTimerFiredEv+0x45) [0xf640a965]
11  0xf6604906 /ramdisk/qt-linux-release/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore13SharedTimerQt10timerEventEP11QTimerEvent+0x46) [0xf6604906]
12  0xf3adf4e4 /usr/local/Trolltech/Qt-4.8.0/lib/libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x84) [0xf3adf4e4]
Comment 13 Csaba Osztrogonác 2012-03-05 03:09:39 PST
(In reply to comment #11)
> (In reply to comment #10)
> > Could you please add information that is useful?  backtrace with line numbers for instance.
> 
> Unfortunately I can't, because bots usually catch these crashes in release mode.
> I'm going to reproduce crashes locally in debug mode.

I tried to reproduce these crashes in debug mode, but I can't. :(
During a night long sputnik test running there wasn't any crash.
Comment 14 Csaba Osztrogonác 2012-03-06 05:36:51 PST
One more similar crash on the performance bot:
Running DOM/CreateNodes.html (5 of 44)
crash: PerformanceTests/DOM/CreateNodes.html
error:
1   0x424628 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/bin/DumpRenderTree() [0x424628]
2   0x7f2ae43d7420 /lib/x86_64-linux-gnu/libc.so.6(+0x36420) [0x7f2ae43d7420]
3   0x7f2ae8676ed4 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC11SlotVisitor5drainEv+0xa4) [0x7f2ae8676ed4]
4   0x7f2ae8671073 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap9markRootsEb+0x1f3) [0x7f2ae8671073]
5   0x7f2ae86730ed /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC4Heap7collectENS0_11SweepToggleE+0x1d) [0x7f2ae86730ed]
6   0x7f2ae76c0f05 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(+0xdcdf05) [0x7f2ae76c0f05]
7   0x7f2ae76c0f6a /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN7WebCore12GCController17garbageCollectNowEv+0x1a) [0x7f2ae76c0f6a]
8   0x427e0b /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/bin/DumpRenderTree() [0x427e0b]
9   0x7f2ae7768c22 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(_ZN3JSC8Bindings19QtRuntimeMetaMethod4callEPNS_9ExecStateE+0xe92) [0x7f2ae7768c22]
10  0x7f2ae86a0957 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(+0x1dad957) [0x7f2ae86a0957]
11  0x7f2ae86a4d44 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.4(operationLinkCallWithReturnAddress+0x44) [0x7f2ae86a4d44]
12  0x7f2a99886fc9 [0x7f2a99886fc9]

FAILED
Finished: 8.071928 s
Comment 15 Csaba Osztrogonác 2012-03-20 00:08:09 PDT
One more crash on the perf bot because of this bug.

Running DOM/CreateNodes.html (6 of 53)
crash: PerformanceTests/DOM/CreateNodes.html
error:
1   0x424188 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/bin/DumpRenderTree() [0x424188]
2   0x7fc14a918420 /lib/x86_64-linux-gnu/libc.so.6(+0x36420) [0x7fc14a918420]
3   0x7fc14ebd42d4 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(_ZN3JSC11SlotVisitor5drainEv+0xa4) [0x7fc14ebd42d4]
4   0x7fc14ebce473 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(_ZN3JSC4Heap9markRootsEb+0x1f3) [0x7fc14ebce473]
5   0x7fc14ebd04fb /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(_ZN3JSC4Heap7collectENS0_11SweepToggleE+0x2b) [0x7fc14ebd04fb]
6   0x7fc14dbfeee5 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(+0xdcaee5) [0x7fc14dbfeee5]
7   0x7fc14dbfef4a /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(_ZN7WebCore12GCController17garbageCollectNowEv+0x1a) [0x7fc14dbfef4a]
8   0x4277fb /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/bin/DumpRenderTree() [0x4277fb]
9   0x7fc14dca7d12 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(_ZN3JSC8Bindings19QtRuntimeMetaMethod4callEPNS_9ExecStateE+0xe92) [0x7fc14dca7d12]
10  0x7fc14ebfdb37 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(+0x1dc9b37) [0x7fc14ebfdb37]
11  0x7fc14ec02024 /home/webkitbuildbot/slaves/release64bit-perf/buildslave/qt-linux-64-release-perf-tests/build/WebKitBuild/Release/lib/libQtWebKit.so.5(operationLinkCallWithReturnAddress+0x44) [0x7fc14ec02024]
12  0x7fc0ffffd269 [0x7fc0ffffd269]
Comment 16 Csaba Osztrogonác 2012-03-20 00:09:10 PDT
Is there anyone Qt and JSC expert interested in fixing this serious bug?
(Or are crashes always features, not bugs?)
Comment 17 Csaba Osztrogonác 2012-05-17 05:24:06 PDT
I can't reproduce it now, it seems time solves everything. :) Unskip landed in r117433.