Bug 7879 - REGRESSION: Dashed borders paint with the wrong phase
Summary: REGRESSION: Dashed borders paint with the wrong phase
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Eric Seidel (no email)
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-03-20 12:28 PST by mitz
Modified: 2006-03-24 01:57 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-03-20 12:28:04 PST
See for example css1/box_properties/border_style.html which fails in pixel mode. It looks like a regression from the GraphicsContext part of r13396 but as much as I looked in GraphicsContext::drawLine() I couldn't figure out what changed.
Comment 1 Alice Liu 2006-03-21 09:45:55 PST
<rdar://problem/4485488>
Comment 2 Eric Seidel (no email) 2006-03-23 00:18:47 PST
Good catch mitz.
Comment 3 mitz 2006-03-24 01:57:38 PST
Verified in r13461 nightly. Thanks, Eric!