Bug 78299 - [chromium] Enable mock scrollbars for compositing layout tests
Summary: [chromium] Enable mock scrollbars for compositing layout tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: James Robinson
URL:
Keywords:
: 72658 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-09 17:38 PST by James Robinson
Modified: 2012-02-13 17:37 PST (History)
7 users (show)

See Also:


Attachments
Patch (338.68 KB, patch)
2012-02-09 17:41 PST, James Robinson
dpranke: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Robinson 2012-02-09 17:38:44 PST
[chromium] Enable mock scrollbars for compositing layout tests
Comment 1 James Robinson 2012-02-09 17:41:28 PST
Created attachment 126412 [details]
Patch
Comment 2 James Robinson 2012-02-09 17:45:55 PST
Committed r107329: <http://trac.webkit.org/changeset/107329>
Comment 3 Adam Barth 2012-02-09 18:07:17 PST
We should probably do this for all tests.
Comment 4 James Robinson 2012-02-09 18:11:02 PST
(In reply to comment #3)
> We should probably do this for all tests.

I think we should, except for a holdout of some tests specifically designed to verify our native theming works.  That's a much bigger job though and these compositing tests were causing acute problems.
Comment 5 Adam Barth 2012-02-09 18:17:29 PST
Oh definitely.  I was just thinking about doing it for all the tests the other day.

Do you know which tests are testing our native theming?  Presumably they won't use our fake scrollbars on Windows or Linux either.
Comment 6 Adrienne Walker 2012-02-13 17:37:42 PST
*** Bug 72658 has been marked as a duplicate of this bug. ***