Bug 77889 - [Chromium] Test fast/forms/listbox-clear-restore.html is flaky
Summary: [Chromium] Test fast/forms/listbox-clear-restore.html is flaky
Status: RESOLVED DUPLICATE of bug 82818
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 11:47 PST by Julien Chaffraix
Modified: 2012-04-27 15:57 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Chaffraix 2012-02-06 11:47:12 PST
Since it was introduced, it has been intermittently failing on 2 Chromium bots:

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=fast%2Fforms%2Flistbox-clear-restore.html

It looks like the scrollbar is not always reset to the first position (0) though I am not sure why this is. I will mark it as flaky for the moment.
Comment 1 Joe Thomas 2012-02-06 12:52:12 PST
I ran this test for 1000 times using --repeat-each on Safari/Mac and it did not fail. I am getting a Chromium port. I will check this on that.
Comment 2 Joe Thomas 2012-02-07 10:13:52 PST
Ran this test on Chromium port on Mac for 1000 times and it is not failing for me. Used the following command to run the test

Tools/Scripts/run-webkit-tests LayoutTests/fast/forms/listbox-clear-restore.html --chromium --iterations 1000 --run-singly
Comment 3 Abhishek Arya 2012-04-27 15:57:20 PDT
Duplicating since other bug has the patch.

*** This bug has been marked as a duplicate of bug 82818 ***