Bug 7765 - hasAttribute always returns false for uppercase attribute names like "STYLE"
Summary: hasAttribute always returns false for uppercase attribute names like "STYLE"
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Critical
Assignee: Darin Adler
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-03-14 09:14 PST by Darin Adler
Modified: 2019-02-06 09:02 PST (History)
1 user (show)

See Also:


Attachments
patch with detailed change log and a layout test (30.07 KB, patch)
2006-03-14 09:28 PST, Darin Adler
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2006-03-14 09:14:41 PST
This is especially important because of a major problem it causes in the Mail application.
Comment 1 Darin Adler 2006-03-14 09:28:59 PST
Created attachment 7061 [details]
patch with detailed change log and a layout test
Comment 2 Darin Adler 2006-03-14 09:29:33 PST
<rdar://problem/4474884> hasAttribute always returns false for uppercase attribute names like "STYLE"
Comment 3 Geoffrey Garen 2006-03-14 09:58:27 PST
Comment on attachment 7061 [details]
patch with detailed change log and a layout test

The new layout test "console" is neat.

"Did not raise an exception as expected" sounds ambiguous to me. I would say, "was expected to raise an exception but didn't" instead.

Am I right that lowercasedName is only actually lower case in the HTML case? Maybe we should just call it something like nameCopy instead.

r=me
Comment 4 Eric Seidel (no email) 2006-03-14 11:38:03 PST
Comment on attachment 7061 [details]
patch with detailed change log and a layout test

I find calling your local variable "lowercasedNamed" sorta odd, when half the time it's actually not lowercased.

You might consider calling it localName or name depending on which of those is already taken.
Comment 5 Eric Seidel (no email) 2006-03-14 11:38:52 PST
Oops, just call me "ggaren2".
Comment 6 Lucas Forschler 2019-02-06 09:02:31 PST
Mass moving XML DOM bugs to the "DOM" Component.